aboutsummaryrefslogtreecommitdiffstats
path: root/community/borgmatic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/borgmatic/APKBUILD')
-rw-r--r--community/borgmatic/APKBUILD49
1 files changed, 34 insertions, 15 deletions
diff --git a/community/borgmatic/APKBUILD b/community/borgmatic/APKBUILD
index 7afd966b2f7..d4220d691b3 100644
--- a/community/borgmatic/APKBUILD
+++ b/community/borgmatic/APKBUILD
@@ -1,45 +1,64 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=borgmatic
-pkgver=1.6.5
-pkgrel=0
+pkgver=1.8.9
+pkgrel=1
pkgdesc="Simple, configuration-driven backup software for servers and workstations"
url="https://torsion.org/borgmatic/"
license="GPL-3.0-or-later"
-arch="noarch !s390x" # tests fail on s390x
+# armhf: limited by borgbackup
+# s390x: tests fail
+arch="noarch !armhf !s390x"
depends="
borgbackup
- python3
- py3-setuptools
+ py3-colorama
py3-jsonschema
+ py3-packaging
py3-requests
py3-ruamel.yaml
- py3-colorama
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
"
checkdepends="
py3-pytest
py3-pytest-cov
py3-flexmock
"
-source="$pkgname-$pkgver.tar.gz::https://projects.torsion.org/borgmatic-collective/borgmatic/archive/$pkgver.tar.gz
- python3.patch
- "
+subpackages="$pkgname-bash-completion $pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://projects.torsion.org/borgmatic-collective/borgmatic/archive/$pkgver.tar.gz"
builddir="$srcdir/borgmatic"
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+
+ python3 -m venv --clear --without-pip --system-site-packages venv
+ ./venv/bin/python3 -m installer \
+ .dist/borgmatic-$pkgver-py3-none-any.whl
+ ./venv/bin/borgmatic --bash-completion > $pkgname.bash
}
check() {
- # omit a simple test that requires borgmatic to be available in $PATH
- pytest -k "not test_borgmatic_version_matches_news_version"
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # Requires apprise package that is currently in testing
+ PATH="$PATH:$builddir/.testenv/bin" .testenv/bin/python3 -m pytest \
+ --ignore=tests/unit/hooks/test_apprise.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 -m installer -d "$pkgdir" \
+ .dist/borgmatic-$pkgver-py3-none-any.whl
+
+ install -Dm644 $pkgname.bash \
+ "$pkgdir"/usr/share/bash-completion/completions/$pkgname
}
sha512sums="
-139fb7382e00f8285ed73cf6f716053bf7fa877a37af7ba98b7c48dc502d07d58c838f416a017dee6bc356a2c7913dc4339efcf234a0cecd7d6775f8f43388c2 borgmatic-1.6.5.tar.gz
-c4561ec75f486f75121f18039e42b166ed7eac4f3a6a2e821410ec0b8f0d1a48f1e5155393d8b735b6554efcf9cfc8ff163bc64b262b0239f86a03ec59ab6652 python3.patch
+65109fb5ece95022cfce44c58bb38ffa63e64913f61ede13d611382b8039ecf37f07fcdb687b1d3ac7e83dba11ed0ccda4a50ff88c48c8100de50125d891a31c borgmatic-1.8.9.tar.gz
"