aboutsummaryrefslogtreecommitdiffstats
path: root/community/breeze-gtk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/breeze-gtk/APKBUILD')
-rw-r--r--community/breeze-gtk/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/breeze-gtk/APKBUILD b/community/breeze-gtk/APKBUILD
index fdbf64dadd6..9c7096cbaae 100644
--- a/community/breeze-gtk/APKBUILD
+++ b/community/breeze-gtk/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=breeze-gtk
-pkgver=5.22.0
+pkgver=6.0.4.1
pkgrel=0
pkgdesc="A GTK Theme Built to Match KDE's Breeze"
# armhf blocked by extra-cmake-modules
-# s390x blocked by breeze
-arch="noarch !armhf !s390x !mips64"
+arch="noarch !armhf"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-only"
depends="gtk-engines"
@@ -15,6 +17,7 @@ makedepends="
breeze-dev
extra-cmake-modules
py3-cairo
+ samurai
sassc
"
@@ -22,24 +25,24 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/breeze-gtk-$pkgver.tar.xz"
+_repo_url="https://invent.kde.org/plasma/breeze-gtk.git"
+source="https://download.kde.org/stable/plasma/${pkgver%.*}/breeze-gtk-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-61ce15452173577d397e79ca131cf6cf150388d3972cac91f73e1aff9209a1a9475feccfb6dbc0e5a877e539e1c2a44cc7635e4f874e031e76f09cc4b49120c5 breeze-gtk-5.22.0.tar.xz
+3a9fd0b9cded7e32a9acc463f00e5a7827f1754f7da44a525de4bfa6e906e2fe002aa22773dc0c9f4a7740409b3eb2a6773ac540fed152952dbef83e86c337f3 breeze-gtk-6.0.4.1.tar.xz
"