aboutsummaryrefslogtreecommitdiffstats
path: root/community/breeze-icons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/breeze-icons/APKBUILD')
-rw-r--r--community/breeze-icons/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/breeze-icons/APKBUILD b/community/breeze-icons/APKBUILD
index b81eca71929..a476322f5f9 100644
--- a/community/breeze-icons/APKBUILD
+++ b/community/breeze-icons/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=breeze-icons
-pkgver=5.97.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Breeze icon themes"
arch="noarch !armhf" # armhf blocked by extra-cmake-modules
@@ -9,12 +12,14 @@ url="https://community.kde.org/Frameworks"
license="LGPL-3.0-or-later"
makedepends="
extra-cmake-modules
+ findutils
py3-lxml
python3
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-checkdepends="bash"
+subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/frameworks/breeze-icons.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/breeze-icons-$pkgver.tar.xz"
# Several KDE applications use icons not yet present in most themes
@@ -25,23 +30,25 @@ source="https://download.kde.org/stable/frameworks/${pkgver%.*}/breeze-icons-$pk
provides="kde-icons"
provider_priority=100
+replaces="breeze-icons5"
+
build() {
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DBINARY_ICONS_RESOURCE=ON
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(dupe|symlink)'
+ ctest --test-dir build --output-on-failure -E '(dupe|symlink)'
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-744921b9eb4d0cf28563f858478601e589321926c3a03ea543c5d32923b3820dcf0d2f3e22c96807d3dac521102dd1527fcaf64ee0e8d99a12356d6bb85a2f14 breeze-icons-5.97.0.tar.xz
+9592b75d22aef6437d03f13fb242d012977b665d043b8066a5f7f49f1f4b282a921bda29b99b8b63156a3bd3a9f616b9bc1eba8423d547d595ff9156d5053d66 breeze-icons-6.1.0.tar.xz
"