aboutsummaryrefslogtreecommitdiffstats
path: root/community/breeze-icons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/breeze-icons/APKBUILD')
-rw-r--r--community/breeze-icons/APKBUILD42
1 files changed, 32 insertions, 10 deletions
diff --git a/community/breeze-icons/APKBUILD b/community/breeze-icons/APKBUILD
index e63c1ec1b94..a476322f5f9 100644
--- a/community/breeze-icons/APKBUILD
+++ b/community/breeze-icons/APKBUILD
@@ -1,32 +1,54 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=breeze-icons
-pkgver=5.88.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Breeze icon themes"
arch="noarch !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="LGPL-3.0-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev"
-checkdepends="bash"
+makedepends="
+ extra-cmake-modules
+ findutils
+ py3-lxml
+ python3
+ qt6-qtbase-dev
+ samurai
+ "
+subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/frameworks/breeze-icons.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/breeze-icons-$pkgver.tar.xz"
+# Several KDE applications use icons not yet present in most themes
+# We want to keep the possibility for users to not use the KDE provided
+# breeze-icons theme however, as hopefully in the future this situation changes
+# Thus let any theme that provides these icons provide "kde-icons" so the user
+# retains their ability to choose their preferred theme
+provides="kde-icons"
+provider_priority=100
+
+replaces="breeze-icons5"
+
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DBINARY_ICONS_RESOURCE=ON
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(dupe|symlink)'
+ ctest --test-dir build --output-on-failure -E '(dupe|symlink)'
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-e66ee04a2e073fe954e97dfd377581715313a041d62740eda7c4b599fd6785ca241f58508afafcb2fb3a8803df72f5e451a213dff7329f6beca87197e8e1f00d breeze-icons-5.88.0.tar.xz
+9592b75d22aef6437d03f13fb242d012977b665d043b8066a5f7f49f1f4b282a921bda29b99b8b63156a3bd3a9f616b9bc1eba8423d547d595ff9156d5053d66 breeze-icons-6.1.0.tar.xz
"