aboutsummaryrefslogtreecommitdiffstats
path: root/community/breeze-plymouth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/breeze-plymouth/APKBUILD')
-rw-r--r--community/breeze-plymouth/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/breeze-plymouth/APKBUILD b/community/breeze-plymouth/APKBUILD
index 4b7bd623be3..946fe366a42 100644
--- a/community/breeze-plymouth/APKBUILD
+++ b/community/breeze-plymouth/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=breeze-plymouth
-pkgver=5.23.4
+pkgver=6.0.3
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://kde.org/"
@@ -10,18 +13,21 @@ license="GPL-2.0-or-later"
makedepends="
extra-cmake-modules
plymouth-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/breeze-plymouth-$pkgver.tar.xz"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/breeze-plymouth.git"
+source="https://download.kde.org/stable/plasma/$pkgver/breeze-plymouth-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DDISTRO_NAME="$(grep PRETTY_NAME /etc/os-release | awk -F = '{ print $2 }')" \
-DDISTRO_VERSION="$(grep VERSION_ID /etc/os-release | awk -F = '{ print $2 }')"
@@ -33,5 +39,5 @@ package() {
}
sha512sums="
-c4dcfbbe7b465f76a53ec99fb6a352a992c08fdb162568d7b533a67e7eacbb8607f24016e9f8acf6b0a7d68e220eef70c6602fdd4cc7cef5acd008253d074b90 breeze-plymouth-5.23.4.tar.xz
+ce7e9dad23d0c0746d3cf769ce1456f57ba04771011ee62d1e02f05d853f9c6056fd628ae887756e5084b4a94a6fe9ed4a6a282c6075a59b5cca9fe128254ac1 breeze-plymouth-6.0.3.tar.xz
"