aboutsummaryrefslogtreecommitdiffstats
path: root/community/breeze-plymouth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/breeze-plymouth/APKBUILD')
-rw-r--r--community/breeze-plymouth/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/community/breeze-plymouth/APKBUILD b/community/breeze-plymouth/APKBUILD
index e4f490feeaa..946fe366a42 100644
--- a/community/breeze-plymouth/APKBUILD
+++ b/community/breeze-plymouth/APKBUILD
@@ -1,28 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=breeze-plymouth
-pkgver=5.22.3
+pkgver=6.0.3
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://kde.org/"
pkgdesc="Breeze theme for Plymouth"
license="GPL-2.0-or-later"
-depends="plymouth"
makedepends="
extra-cmake-modules
plymouth-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/breeze-plymouth-$pkgver.tar.xz"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/breeze-plymouth.git"
+source="https://download.kde.org/stable/plasma/$pkgver/breeze-plymouth-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DDISTRO_NAME="$(grep PRETTY_NAME /etc/os-release | awk -F = '{ print $2 }')" \
-DDISTRO_VERSION="$(grep VERSION_ID /etc/os-release | awk -F = '{ print $2 }')"
@@ -34,5 +39,5 @@ package() {
}
sha512sums="
-90949b4877a9d7c3a1d00dae07c567d59544a1537ddb807146fb342e5514abe82dc8871e359b2542b26b1796746afd28265c83c0cc51bd24f9fa6ff2e28602b4 breeze-plymouth-5.22.3.tar.xz
+ce7e9dad23d0c0746d3cf769ce1456f57ba04771011ee62d1e02f05d853f9c6056fd628ae887756e5084b4a94a6fe9ed4a6a282c6075a59b5cca9fe128254ac1 breeze-plymouth-6.0.3.tar.xz
"