aboutsummaryrefslogtreecommitdiffstats
path: root/community/breeze-plymouth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/breeze-plymouth/APKBUILD')
-rw-r--r--community/breeze-plymouth/APKBUILD33
1 files changed, 24 insertions, 9 deletions
diff --git a/community/breeze-plymouth/APKBUILD b/community/breeze-plymouth/APKBUILD
index ac4e157c236..946fe366a42 100644
--- a/community/breeze-plymouth/APKBUILD
+++ b/community/breeze-plymouth/APKBUILD
@@ -1,20 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=breeze-plymouth
-pkgver=5.18.5
+pkgver=6.0.3
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://kde.org/"
pkgdesc="Breeze theme for Plymouth"
license="GPL-2.0-or-later"
-depends="plymouth"
-makedepends="extra-cmake-modules plymouth-dev"
+makedepends="
+ extra-cmake-modules
+ plymouth-dev
+ samurai
+ "
+
+case "$pkgver" in
+ *.90*) _rel=unstable;;
+ *) _rel=stable;;
+esac
+_repo_url="https://invent.kde.org/plasma/breeze-plymouth.git"
source="https://download.kde.org/stable/plasma/$pkgver/breeze-plymouth-$pkgver.tar.xz"
-options="!check" # No tests
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DDISTRO_NAME="$(grep PRETTY_NAME /etc/os-release | awk -F = '{ print $2 }')" \
-DDISTRO_VERSION="$(grep VERSION_ID /etc/os-release | awk -F = '{ print $2 }')"
@@ -22,7 +35,9 @@ build() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="45206a6c99047b8b68fd5806dce608ddc09c4208c7966ef276bd7096949ad05138ffea2d6272e5c5ed5985ebbde9bfb7ce8b8a1074f56286dd3e1b840937b98d breeze-plymouth-5.18.5.tar.xz"
+sha512sums="
+ce7e9dad23d0c0746d3cf769ce1456f57ba04771011ee62d1e02f05d853f9c6056fd628ae887756e5084b4a94a6fe9ed4a6a282c6075a59b5cca9fe128254ac1 breeze-plymouth-6.0.3.tar.xz
+"