aboutsummaryrefslogtreecommitdiffstats
path: root/community/breeze-plymouth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/breeze-plymouth/APKBUILD')
-rw-r--r--community/breeze-plymouth/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/breeze-plymouth/APKBUILD b/community/breeze-plymouth/APKBUILD
index 3ebb7b9b0d4..b1e76100b17 100644
--- a/community/breeze-plymouth/APKBUILD
+++ b/community/breeze-plymouth/APKBUILD
@@ -1,28 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=breeze-plymouth
-pkgver=5.21.1
+pkgver=6.0.4.1
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://kde.org/"
pkgdesc="Breeze theme for Plymouth"
license="GPL-2.0-or-later"
-depends="plymouth"
makedepends="
extra-cmake-modules
plymouth-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/breeze-plymouth-$pkgver.tar.xz"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/plasma/breeze-plymouth.git"
+source="https://download.kde.org/stable/plasma/${pkgver%.*}/breeze-plymouth-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DDISTRO_NAME="$(grep PRETTY_NAME /etc/os-release | awk -F = '{ print $2 }')" \
-DDISTRO_VERSION="$(grep VERSION_ID /etc/os-release | awk -F = '{ print $2 }')"
@@ -33,4 +38,6 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="8c051717cecdc6e404ea67e4c89244d652b28735871db57cb65926ac8b0838e463c48051aa95dbf483e12be03190721b8af79992ba3b18d5c8fdaeb6a8143910 breeze-plymouth-5.21.1.tar.xz"
+sha512sums="
+8adaee96f55544d904f16fb871bd1969e467cd892d2b15c84324a7538fa8064b3594ea858443907f27a75458c6832d48ec7ea059077c44de945f5a337b1ad110 breeze-plymouth-6.0.4.1.tar.xz
+"