aboutsummaryrefslogtreecommitdiffstats
path: root/community/breezy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/breezy/APKBUILD')
-rw-r--r--community/breezy/APKBUILD38
1 files changed, 22 insertions, 16 deletions
diff --git a/community/breezy/APKBUILD b/community/breezy/APKBUILD
index 633041e87f2..1fce20a23fe 100644
--- a/community/breezy/APKBUILD
+++ b/community/breezy/APKBUILD
@@ -1,17 +1,24 @@
# Maintainer: Pedro Filipe <xpecex@outlook.com>
pkgname=breezy
-pkgver=3.2.1
-pkgrel=1
+pkgver=3.3.4
+pkgrel=2
pkgdesc="Decentralized revision control system"
url="https://www.breezy-vcs.org/"
arch="all"
license="GPL-2.0-or-later"
-depends="py3-configobj py3-six py3-dulwich py3-patiencediff"
-makedepends="python3-dev py3-fastimport py3-gpgme py3-inotify py3-paramiko
- py3-setuptools cython gettext"
+depends="python3 py3-configobj py3-dulwich py3-patiencediff py3-yaml"
+makedepends="
+ cython
+ py3-gpep517
+ py3-setuptools
+ py3-setuptools-gettext
+ py3-setuptools-rust
+ py3-wheel
+ python3-dev
+ "
checkdepends="py3-subunit py3-testtools"
options="!check" # Requires unittest2
-subpackages="$pkgname-doc"
+subpackages="$pkgname-pyc"
source="https://launchpad.net/brz/${pkgver%.*}/$pkgver/+download/breezy-$pkgver.tar.gz"
prepare() {
@@ -21,27 +28,26 @@ prepare() {
}
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
ln -s brz "$pkgdir"/usr/bin/bzr # backwards compatibility
find "$pkgdir"/usr/lib/python3*/site-packages -type d -name tests \
-exec rm -rf {} +
}
-doc() {
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/man "$subpkgdir"/usr/share
- default_doc
-}
-
sha512sums="
-bfbbff1301f7cc13a2d59b1add80c196f3b45b69994194dcae96c0be151f807c965854047c86e43f54dd8c7aa24d56b25afdd00f0063e83b362a8c46d5858226 breezy-3.2.1.tar.gz
+7619c31acbfdf8cd8193db4a87851ac41376bff3e4a9eb130d7d940fb458a6d064a0fb089888368ddd654e4b965772dd657553cdda20a91e32ab43760b0897b4 breezy-3.3.4.tar.gz
"