aboutsummaryrefslogtreecommitdiffstats
path: root/community/brlaser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/brlaser/APKBUILD')
-rw-r--r--community/brlaser/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/community/brlaser/APKBUILD b/community/brlaser/APKBUILD
index 370aa153946..1343637e563 100644
--- a/community/brlaser/APKBUILD
+++ b/community/brlaser/APKBUILD
@@ -1,29 +1,31 @@
# Contributor: Isaac Dunham <ibid.ag@gmail.com>
-# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer:
pkgname=brlaser
pkgver=6
-pkgrel=0
+pkgrel=3
pkgdesc="Driver for Brother printers like the DCP 7030 and DCP 7065"
url="https://github.com/pdewacht/brlaser"
arch="all"
license="GPL-2.0-or-later"
depends="cups-filters"
-makedepends="cmake cups-dev"
+makedepends="cmake cups-dev samurai"
source="brlaser-$pkgver.tar.gz::https://github.com/pdewacht/brlaser/archive/v$pkgver.tar.gz"
build() {
- cmake -B build . \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr
- make -C build
+ cmake --build build
}
check() {
- make -C build test
+ ctest --test-dir build
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="d7e0e63b64be9ae7633381622c13ba0589e5fe58d277212bce4f5bb712a291ed0b0f2ac3d450dce61c7f9052c1ce7323fec66b5005c5cb3da1314b284d20f06f brlaser-6.tar.gz"
+sha512sums="
+d7e0e63b64be9ae7633381622c13ba0589e5fe58d277212bce4f5bb712a291ed0b0f2ac3d450dce61c7f9052c1ce7323fec66b5005c5cb3da1314b284d20f06f brlaser-6.tar.gz
+"