aboutsummaryrefslogtreecommitdiffstats
path: root/community/btop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/btop/APKBUILD')
-rw-r--r--community/btop/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/btop/APKBUILD b/community/btop/APKBUILD
new file mode 100644
index 00000000000..45ad08bcfde
--- /dev/null
+++ b/community/btop/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=btop
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="Resource monitor"
+url="https://github.com/aristocratos/btop"
+license="Apache-2.0"
+arch="all"
+makedepends="cmd:fmt"
+source="https://github.com/aristocratos/btop/archive/v$pkgver/btop-$pkgver.tar.gz"
+options="!check" # no test suite
+
+build() {
+ ADDFLAGS="-fno-ipa-cp" make
+}
+
+package() {
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+
+ rm "$pkgdir"/usr/share/btop/README.md
+}
+
+sha512sums="
+9bbe983aa1336566f78396b829d49c22fe709e4e3d959dabc7524b61defba2638f3b0c50658f755fd1f02dd70572c78cc3cfc8b01772e174d0f34a48e4e178b2 btop-1.3.2.tar.gz
+"