aboutsummaryrefslogtreecommitdiffstats
path: root/community/bubblejail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bubblejail/APKBUILD')
-rw-r--r--community/bubblejail/APKBUILD52
1 files changed, 38 insertions, 14 deletions
diff --git a/community/bubblejail/APKBUILD b/community/bubblejail/APKBUILD
index 5f60fd7a5ee..8a5bf56e79b 100644
--- a/community/bubblejail/APKBUILD
+++ b/community/bubblejail/APKBUILD
@@ -1,30 +1,54 @@
# Maintainer: Donoban <donoban@riseup.net>
pkgname=bubblejail
-pkgver=0.4.2
-pkgrel=0
+pkgver=0.8.3
+pkgrel=1
pkgdesc="Bubblewrap based sandboxing for desktop applications"
url="https://github.com/igo95862/bubblejail"
arch="noarch"
license="GPL-3.0-or-later"
-depends="python3 bubblewrap py3-xdg py3-toml"
-makedepends="meson m4 py3-sphinx fish"
-subpackages="$pkgname-doc
+depends="
+ bubblewrap
+ libseccomp
+ py3-tomli-w
+ py3-xdg
+ xdg-dbus-proxy
+ "
+makedepends="
+ meson
+ scdoc
+ py3-jinja2
+ "
+subpackages="
+ $pkgname-doc
+ $pkgname-pyc
$pkgname-bash-completion
- $pkgname-fish-completion"
-source="bubblejail-$pkgver.tar.gz::https://github.com/igo95862/bubblejail/archive/refs/tags/$pkgver.tar.gz
- fish_completions.patch
- ld_cache.patch"
+ $pkgname-fish-completion
+ $pkgname-config
+ "
+source="bubblejail-$pkgver.tar.gz::https://github.com/igo95862/bubblejail/archive/refs/tags/$pkgver.tar.gz"
options="!check" # No tests
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Duse_python_site_packages_dir=true \
+ -Dversion_display="Alpine $pkgver" \
+ -Dbytecode-optimization=0 \
+ . output
+ meson compile -C output
}
package() {
DESTDIR=$pkgdir meson install --no-rebuild -C output
+ # the meson toggle doesn't work to disable this
+ find "$pkgdir" -name "*.opt-1.pyc" -delete
}
-sha512sums="c619a90830d7af0d64863369107708c782c3cc43d8afa16785d4fb62c00b532962039a47338214c57045f810f130f9cd5c4a9677c0f53a0565aae4fddbeb0422 bubblejail-0.4.2.tar.gz
-75cac90d0c4689bb29714aa4cd8ad507f4c8a813927c34d9c1aede3d5316bca219225848f45bca3ce9e5d103df7c9fa6059dd932fdd946297a15ccd9616aef38 fish_completions.patch
-5a78e5da4e06b43bd4e0198d1924eeed792b45ba1db12ec1d957afc99ed8653c793a0a5d978a2910194a26974bf04d595bb60df6eba52ccc76c7103aa8aa7cd2 ld_cache.patch"
+config() {
+ depends="$pkgname=$pkgver-r$pkgrel py3-qt6"
+ amove /usr/bin/bubblejail-config
+ amove /usr/lib/python3.*/site-packages/bubblejail/bubblejail_gui_qt.py
+}
+
+sha512sums="
+c1b74d70d546a40b72c52b3b36a2f2b75cb21767b380575780dfc6a77364489b1d44269535c990e68bcf318422a1c27586486c4b62d398bf07d91beb5e099e0a bubblejail-0.8.3.tar.gz
+"