aboutsummaryrefslogtreecommitdiffstats
path: root/community/buho/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/buho/APKBUILD')
-rw-r--r--community/buho/APKBUILD43
1 files changed, 25 insertions, 18 deletions
diff --git a/community/buho/APKBUILD b/community/buho/APKBUILD
index 75decf27323..08b4ecab90a 100644
--- a/community/buho/APKBUILD
+++ b/community/buho/APKBUILD
@@ -1,41 +1,49 @@
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
pkgname=buho
-pkgver=2.0.0
-pkgrel=1
+pkgver=3.0.2
+pkgrel=0
pkgdesc="Note taking app based on MauiKit"
# armhf blocked by qt5-qtdeclarative
-# s390x, ppc64le, mips64 and riscv64 blocked by qt5-qtwebview
-arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
+# s390x, ppc64le and riscv64 blocked by qt5-qtwebview
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://invent.kde.org/maui/buho"
license="GPL-2.0-or-later"
depends="
+ kde-icons
mauikit-texteditor
"
makedepends="
- attica-dev
+ attica5-dev
extra-cmake-modules
- kconfig-dev
- ki18n-dev
- kio-dev
- knotifications-dev
+ kconfig5-dev
+ ki18n5-dev
+ kio5-dev
+ knotifications5-dev
mauikit-dev
mauikit-accounts-dev
mauikit-filebrowsing-dev
+ mauikit-texteditor-dev
qt5-qtbase-dev
+ qt5-qtbase-sqlite
qt5-qtdeclarative-dev
qt5-qtquickcontrols2-dev
qt5-qtsvg-dev
qt5-qtwebview-dev
- syntax-highlighting-dev
- "
-source="https://download.kde.org/stable/maui/buho/$pkgver/buho-$pkgver.tar.xz
- 0001-fix-build.patch
+ samurai
+ syntax-highlighting5-dev
"
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/maui/buho.git"
+source="https://download.kde.org/stable/maui/buho/$pkgver/buho-$pkgver.tar.xz"
options="!check" # No tests available
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -45,6 +53,5 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-3ec3dd5344e6a41dfe1127ec89f087f8203cca8eecf1e3fa4e7a4b925c67331e5057488f8773d395c5a351ec5d5a4059d9ed041d164b13371cefc1bde51f565a buho-2.0.0.tar.xz
-0d649ca94e3f06d6b9c11bee0441021e019535ec6b844f8bf0c80f55901aa6ffe0f7aafd13b36ad157d06196d8b3bcf27e0f8a88ff97c9480a63c11e5b5d3185 0001-fix-build.patch
+7a3cd72fd13c6bf82045fcdd2fe3f0d246bb44eead73f11bd2a80eedd0ba3f381481dfd9048699a7f99c14b5b430488062c2a39983475a25d460b901c5fb0e7c buho-3.0.2.tar.xz
"