aboutsummaryrefslogtreecommitdiffstats
path: root/community/buho/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/buho/APKBUILD')
-rw-r--r--community/buho/APKBUILD53
1 files changed, 41 insertions, 12 deletions
diff --git a/community/buho/APKBUILD b/community/buho/APKBUILD
index c24243b86ac..08b4ecab90a 100644
--- a/community/buho/APKBUILD
+++ b/community/buho/APKBUILD
@@ -1,28 +1,57 @@
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
pkgname=buho
-pkgver=1.1.1
+pkgver=3.0.2
pkgrel=0
pkgdesc="Note taking app based on MauiKit"
# armhf blocked by qt5-qtdeclarative
-# s390x, ppc64le, mips and mips64 blocked by qt5-qtwebview
-arch="all !armhf !s390x !ppc64le !mips !mips64"
+# s390x, ppc64le and riscv64 blocked by qt5-qtwebview
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://invent.kde.org/maui/buho"
license="GPL-2.0-or-later"
-depends="mauikit"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtsvg-dev qt5-qtquickcontrols2-dev qt5-qtwebview-dev mauikit-dev kconfig-dev kio-dev knotifications-dev ki18n-dev attica-dev syntax-highlighting-dev"
-source="https://invent.kde.org/maui/buho/-/archive/v$pkgver/buho-v$pkgver.tar.gz"
+depends="
+ kde-icons
+ mauikit-texteditor
+ "
+makedepends="
+ attica5-dev
+ extra-cmake-modules
+ kconfig5-dev
+ ki18n5-dev
+ kio5-dev
+ knotifications5-dev
+ mauikit-dev
+ mauikit-accounts-dev
+ mauikit-filebrowsing-dev
+ mauikit-texteditor-dev
+ qt5-qtbase-dev
+ qt5-qtbase-sqlite
+ qt5-qtdeclarative-dev
+ qt5-qtquickcontrols2-dev
+ qt5-qtsvg-dev
+ qt5-qtwebview-dev
+ samurai
+ syntax-highlighting5-dev
+ "
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/maui/buho.git"
+source="https://download.kde.org/stable/maui/buho/$pkgver/buho-$pkgver.tar.xz"
options="!check" # No tests available
-builddir="$srcdir/$pkgname-v$pkgver"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="b6587d7c0fadff3c4a9484797b631e7f2e9064b1e907186dc98439c68be1a27dbbb06189f3c02ada716e1bfe83510fa9bf01b5300d80aec00b2c89c1ae3d2ee8 buho-v1.1.1.tar.gz"
+sha512sums="
+7a3cd72fd13c6bf82045fcdd2fe3f0d246bb44eead73f11bd2a80eedd0ba3f381481dfd9048699a7f99c14b5b430488062c2a39983475a25d460b901c5fb0e7c buho-3.0.2.tar.xz
+"