aboutsummaryrefslogtreecommitdiffstats
path: root/community/buildah/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/buildah/APKBUILD')
-rw-r--r--community/buildah/APKBUILD27
1 files changed, 21 insertions, 6 deletions
diff --git a/community/buildah/APKBUILD b/community/buildah/APKBUILD
index de1c58f76b8..c1abf48b940 100644
--- a/community/buildah/APKBUILD
+++ b/community/buildah/APKBUILD
@@ -2,19 +2,25 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=buildah
-pkgver=1.23.1
-pkgrel=1
+pkgver=1.34.1
+pkgrel=2
pkgdesc="tool that facilitates building OCI container images"
url="https://github.com/containers/buildah"
license="Apache-2.0"
arch="all"
-depends="crun shadow-subids fuse-overlayfs slirp4netns containers-common"
+depends="oci-runtime shadow-subids slirp4netns containers-common"
makedepends="go go-md2man lvm2-dev gpgme-dev libseccomp-dev btrfs-progs-dev bash"
subpackages="$pkgname-doc"
options="!check" # tests require root privileges
-source="https://github.com/containers/buildah/archive/v$pkgver/buildah-$pkgver.tar.gz"
+source="https://github.com/containers/buildah/archive/v$pkgver/buildah-$pkgver.tar.gz
+ basename.patch
+ "
# secfixes:
+# 1.34.0-r1:
+# - CVE-2023-48795
+# 1.28.0-r0:
+# - CVE-2022-2990
# 1.21.3-r0:
# - CVE-2021-3602
# 1.19.4-r0:
@@ -22,8 +28,16 @@ source="https://github.com/containers/buildah/archive/v$pkgver/buildah-$pkgver.t
# 1.14.4-r0:
# - CVE-2020-10696
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
- GIT_COMMIT="$pkgver" make
+ # https://github.com/mattn/go-sqlite3/issues/1164
+ export CGO_CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
+
+ GIT_COMMIT="$pkgver" make buildah
+ GIT_COMMIT="$pkgver" make -C docs GOMD2MAN="$(which go-md2man)"
}
package() {
@@ -31,5 +45,6 @@ package() {
}
sha512sums="
-2ceb6df5adb671483557bb03937df583857d99c116be5d44aae533c155f560d5d454bebf25908ac02bb85e4c2ba31533adb99f0946ecc4f4830977c14f324b6f buildah-1.23.1.tar.gz
+2d229ead1149b66d1b7d91f596809e97e5316356ab0997ea335eb3e246ed8bc6879e0e260bb478b4d7ec7c42c7dbf33d0e91086a34e89a3b79eb27322da06c1e buildah-1.34.1.tar.gz
+640526de31a5eb21112c3d3fd30ce78331e5f5998166c9af9405ebad919a9a895ee82e3eed7067c2ce7e3e558e31907398fec1ad895be708e9f8ada696076216 basename.patch
"