aboutsummaryrefslogtreecommitdiffstats
path: root/community/cairomm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cairomm/APKBUILD')
-rw-r--r--community/cairomm/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/community/cairomm/APKBUILD b/community/cairomm/APKBUILD
index fe9da626af3..1ea49a67aea 100644
--- a/community/cairomm/APKBUILD
+++ b/community/cairomm/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cairomm
-pkgver=1.14.0
+pkgver=1.14.5
pkgrel=0
pkgdesc="C++ bindings to Cairo vector graphics library"
url="https://www.cairographics.org"
@@ -12,13 +12,16 @@ source="https://www.cairographics.org/releases/cairomm-$pkgver.tar.xz"
build() {
abuild-meson \
+ -Db_lto=true \
-Dboost-shared=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="05d2123a53700f3d0092e75c798847883493d3f803b2f6f47511ea0008d42e417688a00f1a0d50bda97a9661da9141185709011859c9390f0bece5b093c0acf6 cairomm-1.14.0.tar.xz"
+sha512sums="
+19e5f84f6167c1641b27545c3af4e780b6a072513322adc6296577e2d0ebcffe933afd15c32117a203394e9f5f28734820aaf1802dfdeb35ff2a657f140570b0 cairomm-1.14.5.tar.xz
+"