aboutsummaryrefslogtreecommitdiffstats
path: root/community/callaudiod/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/callaudiod/APKBUILD')
-rw-r--r--community/callaudiod/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/callaudiod/APKBUILD b/community/callaudiod/APKBUILD
index 3e8f83e4af7..8ce8329a04a 100644
--- a/community/callaudiod/APKBUILD
+++ b/community/callaudiod/APKBUILD
@@ -1,27 +1,29 @@
# Contributor: TimotheeLF <timotheel-f@protonmail.com>
# Maintainer: TimotheeLF <timotheel-f@protonmail.com>
pkgname=callaudiod
-pkgver=0.1.0
+pkgver=0.1.9
pkgrel=0
pkgdesc="Call audio routing daemon"
url="https://gitlab.com/mobian1/callaudiod"
arch="all"
license="LGPL-3.0-or-later"
makedepends="meson alsa-lib-dev glib-dev pulseaudio-dev"
-source="https://gitlab.com/mobian1/callaudiod/-/archive/$pkgver/callaudiod-$pkgver.tar.gz"
subpackages="$pkgname-dev $pkgname-libs"
+source="https://gitlab.com/mobian1/callaudiod/-/archive/$pkgver/callaudiod-$pkgver.tar.gz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="a316b2bb5ed9822f00a8c224e22ea9020e81a1c03378bcd63557532b47c582a3822c9d6b9ad8efe572688379c0cc536249e2f385bcc1679c2f3bb9e9db1cc074 callaudiod-0.1.0.tar.gz"
+sha512sums="
+8e0bcf6f6c1d09d70afec2f6bad9bd63bc417bb46a4e15d5b4023b026087e412b1fbf2a41b2c64206e92fcd93fb97aba387d04cb50fbd4923df2d771bad21eab callaudiod-0.1.9.tar.gz
+"