aboutsummaryrefslogtreecommitdiffstats
path: root/community/callaudiod/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/callaudiod/APKBUILD')
-rw-r--r--community/callaudiod/APKBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/community/callaudiod/APKBUILD b/community/callaudiod/APKBUILD
index 1d0a94cfada..8ce8329a04a 100644
--- a/community/callaudiod/APKBUILD
+++ b/community/callaudiod/APKBUILD
@@ -1,25 +1,23 @@
# Contributor: TimotheeLF <timotheel-f@protonmail.com>
# Maintainer: TimotheeLF <timotheel-f@protonmail.com>
pkgname=callaudiod
-pkgver=0.1.1
-pkgrel=1
+pkgver=0.1.9
+pkgrel=0
pkgdesc="Call audio routing daemon"
url="https://gitlab.com/mobian1/callaudiod"
arch="all"
license="LGPL-3.0-or-later"
makedepends="meson alsa-lib-dev glib-dev pulseaudio-dev"
-source="https://gitlab.com/mobian1/callaudiod/-/archive/$pkgver/callaudiod-$pkgver.tar.gz
- exclude-hdmi-audio-devices.patch
- "
subpackages="$pkgname-dev $pkgname-libs"
+source="https://gitlab.com/mobian1/callaudiod/-/archive/$pkgver/callaudiod-$pkgver.tar.gz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -27,6 +25,5 @@ package() {
}
sha512sums="
-e2de6e0bfad6ccf21c106b6750c015cd70a20836634892cbca942394dfb20af36c4ab307f3f68fba210d11106a13bb41847d85f94ff5225e9fd8d04285c9ee89 callaudiod-0.1.1.tar.gz
-8a51213445c676c762ff9c389e00633fe9ce48d430f506eb16caedaa6817b847c6aca86ef646e6315843764699c70b6defcf00bfc0214b2415a53c5cff57b4f3 exclude-hdmi-audio-devices.patch
+8e0bcf6f6c1d09d70afec2f6bad9bd63bc417bb46a4e15d5b4023b026087e412b1fbf2a41b2c64206e92fcd93fb97aba387d04cb50fbd4923df2d771bad21eab callaudiod-0.1.9.tar.gz
"