aboutsummaryrefslogtreecommitdiffstats
path: root/community/calligra/fix-linking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/calligra/fix-linking.patch')
-rw-r--r--community/calligra/fix-linking.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/community/calligra/fix-linking.patch b/community/calligra/fix-linking.patch
deleted file mode 100644
index b9d68221192..00000000000
--- a/community/calligra/fix-linking.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index deca38e..4b1e910 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -641,8 +641,8 @@ if(NOT WIN32 AND NOT APPLE)
- )
- endif()
-
--if(NOT FONTCONFIG_FOUND OR NOT FREETYPE_FOUND)
-- set(FONTCONFIG_INCLUDE_DIR "")
-+if(NOT Fontconfig_FOUND OR NOT FREETYPE_FOUND)
-+ set(Fontconfig_INCLUDE_DIR "")
- set(FREETYPE_INCLUDE_DIRS "")
- else()
- add_definitions( -DSHOULD_BUILD_FONT_CONVERSION )
-diff --git a/libs/text/CMakeLists.txt b/libs/text/CMakeLists.txt
-index 16d7e06..0ba3024 100644
---- a/libs/text/CMakeLists.txt
-+++ b/libs/text/CMakeLists.txt
-@@ -152,11 +152,11 @@ if( SHOULD_BUILD_FEATURE_RDF )
- endif()
-
- if( FONTCONFIG_FOUND )
-- target_link_libraries(kotext PRIVATE ${FONTCONFIG_LIBRARIES})
-+ target_link_libraries(kotext PRIVATE Fontconfig::Fontconfig)
- endif()
-
- if( FREETYPE_FOUND )
-- target_link_libraries(kotext PRIVATE ${FREETYPE_LIBRARIES})
-+ target_link_libraries(kotext PRIVATE Freetype::Freetype)
- endif()
-
-