aboutsummaryrefslogtreecommitdiffstats
path: root/community/can-utils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/can-utils/APKBUILD')
-rw-r--r--community/can-utils/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/can-utils/APKBUILD b/community/can-utils/APKBUILD
index 7b88138a807..6d86a63651a 100644
--- a/community/can-utils/APKBUILD
+++ b/community/can-utils/APKBUILD
@@ -1,21 +1,21 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=can-utils
-pkgver=2021.08.0
+pkgver=2023.03
pkgrel=0
pkgdesc="SocketCAN userspace utilities and tools"
url="https://github.com/linux-can/can-utils"
arch="all"
license="GPL-2.0-only AND BSD-3-Clause"
options="!check" # package don't have tests
-makedepends="cmake linux-headers"
+makedepends="cmake linux-headers samurai"
source="$pkgname-$pkgver.tar.gz::https://github.com/linux-can/can-utils/archive/v$pkgver.tar.gz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
@@ -26,8 +26,11 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
+
+ # not installed with cmake
+ install -Dm755 build/can-calc-bit-timing -t "$pkgdir"/usr/bin/
}
sha512sums="
-367dc19fc653abda0cd6f843f51487f0c538d691542a1a7f5acb87a82b72efb0da5351568de87cd7d3894eaa53b7271e56d8cb66fa2f55079ed0bb1e015dcd99 can-utils-2021.08.0.tar.gz
+bf8f3e555bada4ce1e6f308b46daaab51664a0b6a1b793dc1a2aab46b44331f59635051eb3e75cb9b39999369a7fd463421a89ab60e74bc76ef2d84f6519c501 can-utils-2023.03.tar.gz
"