aboutsummaryrefslogtreecommitdiffstats
path: root/community/cassandra-cpp-driver/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cassandra-cpp-driver/APKBUILD')
-rw-r--r--community/cassandra-cpp-driver/APKBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/community/cassandra-cpp-driver/APKBUILD b/community/cassandra-cpp-driver/APKBUILD
index 4f3fdfa5f61..9798dfd30c4 100644
--- a/community/cassandra-cpp-driver/APKBUILD
+++ b/community/cassandra-cpp-driver/APKBUILD
@@ -3,33 +3,29 @@
pkgname=cassandra-cpp-driver
_pkgname=cpp-driver
pkgver=2.16.2
-pkgrel=0
+pkgrel=2
pkgdesc="Cassandra CPP Driver"
url="https://datastax.github.io/cpp-driver/"
arch="aarch64 x86_64 x86 ppc64le"
license="Apache-2.0"
-options="!check" # FIXME: cassandra_integration_tests won't link
-makedepends="cmake make openssl-dev>3 libuv-dev zlib-dev"
+options="!check" # FIXME: cassandra_integration_tests won't link
+makedepends="cmake make openssl-dev>3 libuv-dev zlib-dev samurai"
subpackages="$pkgname-dev"
source="$_pkgname-$pkgver.tar.gz::https://github.com/datastax/cpp-driver/archive/$pkgver.tar.gz
"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- mkdir -p "$builddir"/build
- cd "$builddir"/build
- export CXXFLAGS="$CXXFLAGS -Wno-error=deprecated-copy -Wno-error=type-limits"
- cmake \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCASS_BUILD_STATIC=ON \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib ..
- make
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
}
package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="