aboutsummaryrefslogtreecommitdiffstats
path: root/community/catch2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/catch2/APKBUILD')
-rw-r--r--community/catch2/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/community/catch2/APKBUILD b/community/catch2/APKBUILD
index 1a1e13166ac..e055dc8c878 100644
--- a/community/catch2/APKBUILD
+++ b/community/catch2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=catch2
-pkgver=2.13.9
+pkgver=2.13.10
pkgrel=0
arch="all"
url="https://github.com/catchorg/Catch2"
@@ -10,17 +10,17 @@ license="BSL-1.0"
makedepends="
cmake
python3
+ samurai
"
source="https://github.com/catchorg/Catch2/archive/v$pkgver/catch2-v$pkgver.tar.gz"
subpackages="$pkgname-doc"
builddir="$srcdir/Catch2-$pkgver"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=TRUE
+ -DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
@@ -35,5 +35,5 @@ package() {
}
sha512sums="
-4a254a20a1d916c14ffa072daa3d371d9ad4b5eb4d3c9257301c7c2ae9171116701cca2438a66ab731604c5b7a9cf4336197a31e32b8ca9bcf93db64bbba344b catch2-v2.13.9.tar.gz
+33c2292d5d315128a73f8cff27e92f86f3af30c45ce199297110b3cd2bf7d67a972fbcf7415aed1c467c384e0e3c63900c90faedff1d74c9d94b9e3e43df5ee2 catch2-v2.13.10.tar.gz
"