aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot-apache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/certbot-apache/APKBUILD')
-rw-r--r--community/certbot-apache/APKBUILD38
1 files changed, 27 insertions, 11 deletions
diff --git a/community/certbot-apache/APKBUILD b/community/certbot-apache/APKBUILD
index 5f1ae6e85c5..1a7dccc490d 100644
--- a/community/certbot-apache/APKBUILD
+++ b/community/certbot-apache/APKBUILD
@@ -1,29 +1,45 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=certbot-apache
-pkgver=1.28.0
-pkgrel=0
+pkgver=2.10.0
+pkgrel=1
pkgdesc="Apache plugin for Certbot client"
-url="https://pypi.org/project/certbot-apache/"
+url="https://github.com/certbot/certbot"
arch="noarch"
license="Apache-2.0"
-depends="certbot py3-acme py3-mock py3-augeas
- py3-setuptools py3-pip py3-zope-component py3-zope-interface"
-checkdepends="py3-pytest"
-source="https://pypi.io/packages/source/c/certbot-apache/certbot-apache-$pkgver.tar.gz"
+depends="
+ certbot
+ py3-acme
+ py3-augeas
+ py3-setuptools
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="py3-pytest-xdist"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/refs/tags/v$pkgver.tar.gz"
+
+builddir="$srcdir/certbot-$pkgver/$pkgname"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto -p no:warnings
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-a45d3ec5395e6671a2fddc8c77849a78d8bd049a844a58b52b62a973c863651f55292339740846fec12414133f24de57848805bfc86b05e2c046c701dcba99ad certbot-apache-1.28.0.tar.gz
+444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd certbot-apache-2.10.0.tar.gz
"