aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot-apache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/certbot-apache/APKBUILD')
-rw-r--r--community/certbot-apache/APKBUILD38
1 files changed, 28 insertions, 10 deletions
diff --git a/community/certbot-apache/APKBUILD b/community/certbot-apache/APKBUILD
index c2b8f4c6714..1a7dccc490d 100644
--- a/community/certbot-apache/APKBUILD
+++ b/community/certbot-apache/APKBUILD
@@ -1,27 +1,45 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=certbot-apache
-pkgver=1.6.0
+pkgver=2.10.0
pkgrel=1
pkgdesc="Apache plugin for Certbot client"
-url="https://pypi.org/project/certbot-apache/"
+url="https://github.com/certbot/certbot"
arch="noarch"
license="Apache-2.0"
-depends="certbot py3-acme py3-mock py3-augeas
- py3-setuptools py3-zope-component py3-zope-interface"
-checkdepends="py3-pytest"
-source="https://pypi.io/packages/source/c/certbot-apache/certbot-apache-$pkgver.tar.gz"
+depends="
+ certbot
+ py3-acme
+ py3-augeas
+ py3-setuptools
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="py3-pytest-xdist"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/refs/tags/v$pkgver.tar.gz"
+
+builddir="$srcdir/certbot-$pkgver/$pkgname"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto -p no:warnings
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="cb5a09eacc91c218154307645f1de4c80bf5cf5aa139a46dca25a07d6eee237c2fd5eddda1841082d148d4c428a49967b00ee97d303616ea06d468b40fff7012 certbot-apache-1.6.0.tar.gz"
+sha512sums="
+444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd certbot-apache-2.10.0.tar.gz
+"