aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot-nginx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/certbot-nginx/APKBUILD')
-rw-r--r--community/certbot-nginx/APKBUILD38
1 files changed, 27 insertions, 11 deletions
diff --git a/community/certbot-nginx/APKBUILD b/community/certbot-nginx/APKBUILD
index 7882a43597c..d666ceaf908 100644
--- a/community/certbot-nginx/APKBUILD
+++ b/community/certbot-nginx/APKBUILD
@@ -1,29 +1,45 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=certbot-nginx
-pkgver=1.27.0
-pkgrel=0
+pkgver=2.10.0
+pkgrel=1
pkgdesc="Nginx plugin for Certbot client"
-url="https://pypi.org/project/certbot-nginx/"
+url="https://github.com/certbot/certbot"
arch="noarch"
license="Apache-2.0"
-depends="certbot py3-acme py3-mock py3-openssl py3-parsing
- py3-setuptools py3-pip py3-zope-interface"
-checkdepends="py3-pytest"
-source="https://pypi.io/packages/source/c/certbot-nginx/certbot-nginx-$pkgver.tar.gz"
+depends="
+ certbot
+ py3-acme
+ py3-openssl
+ py3-parsing
+ py3-setuptools
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="py3-pytest-xdist"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/certbot-$pkgver/$pkgname"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto -p no:warnings
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-7516933c36bd87860fd3efb8b987575946df51cc85d673b10ee15d801dfca9872dc709261390247094f888b9b14ce201c5d302bdc3dc310c508c22e27796f9b0 certbot-nginx-1.27.0.tar.gz
+444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd certbot-nginx-2.10.0.tar.gz
"