aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/certbot/APKBUILD')
-rw-r--r--community/certbot/APKBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/community/certbot/APKBUILD b/community/certbot/APKBUILD
index 5ce37f7329c..54588e54efa 100644
--- a/community/certbot/APKBUILD
+++ b/community/certbot/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=certbot
-pkgver=1.28.0
+pkgver=2.9.0
pkgrel=0
pkgdesc="An ACME client that can update Apache/Nginx configurations"
url="https://github.com/certbot/certbot"
@@ -17,27 +17,35 @@ depends="
py3-josepy
py3-parsedatetime
py3-pyrfc3339
- py3-tz
py3-setuptools
- py3-zope-component
- py3-zope-interface
-"
-checkdepends="py3-augeas py3-pytest"
-replaces="letsencrypt"
-source="https://pypi.io/packages/source/c/certbot/certbot-$pkgver.tar.gz"
+ py3-tz
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="py3-augeas py3-pytest-xdist"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/certbot-$pkgver/$pkgname"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto -p no:warnings
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-102fcd727e864274e432123a134010204d60168bdacb7eaac3bb201fd60a628198651901591971321b56177f584ee2dea349c4102e38bd1bcfe4ac1597ecd8b1 certbot-1.28.0.tar.gz
+27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546 certbot-2.9.0.tar.gz
"