aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/certbot/APKBUILD')
-rw-r--r--community/certbot/APKBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/community/certbot/APKBUILD b/community/certbot/APKBUILD
index 5ce37f7329c..44a5f2b4bc7 100644
--- a/community/certbot/APKBUILD
+++ b/community/certbot/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=certbot
-pkgver=1.28.0
-pkgrel=0
+pkgver=2.10.0
+pkgrel=1
pkgdesc="An ACME client that can update Apache/Nginx configurations"
url="https://github.com/certbot/certbot"
arch="noarch"
@@ -17,27 +17,35 @@ depends="
py3-josepy
py3-parsedatetime
py3-pyrfc3339
- py3-tz
py3-setuptools
- py3-zope-component
- py3-zope-interface
-"
-checkdepends="py3-augeas py3-pytest"
-replaces="letsencrypt"
-source="https://pypi.io/packages/source/c/certbot/certbot-$pkgver.tar.gz"
+ py3-tz
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="py3-augeas py3-pytest-xdist"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/certbot/certbot/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/certbot-$pkgver/$pkgname"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto -p no:warnings
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-102fcd727e864274e432123a134010204d60168bdacb7eaac3bb201fd60a628198651901591971321b56177f584ee2dea349c4102e38bd1bcfe4ac1597ecd8b1 certbot-1.28.0.tar.gz
+444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd certbot-2.10.0.tar.gz
"