aboutsummaryrefslogtreecommitdiffstats
path: root/community/cgif/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cgif/APKBUILD')
-rw-r--r--community/cgif/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/cgif/APKBUILD b/community/cgif/APKBUILD
index 0945c7b4143..2f8dd1368b1 100644
--- a/community/cgif/APKBUILD
+++ b/community/cgif/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Alex Yam <alex@alexyam.com>
# Maintainer: Alex Yam <alex@alexyam.com>
pkgname=cgif
-pkgver=0.3.0
+pkgver=0.3.2
pkgrel=0
pkgdesc="fast and lightweight GIF encoder written in C"
url="https://github.com/dloebl/cgif"
@@ -13,13 +13,14 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/dloebl/cgif/archive/refs/tag
build() {
abuild-meson \
+ -Db_lto=true \
-Dtests=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -27,5 +28,5 @@ package() {
}
sha512sums="
-b5142ab19915fb679d764f2151d094dc5f969ac0d5cac556d42b0305cb78443f4171093af3fea51f50904f31482fc9e132d480a7045ce7dce95257aae12be9fe cgif-0.3.0.tar.gz
+6436a5fc0c77719266d3f0f41a29400861e1e58fa2132b586467b87c4419f95b7514faeec9f738c390a108023de2af2521b8e909452af60ab7a641cc87631dca cgif-0.3.2.tar.gz
"