aboutsummaryrefslogtreecommitdiffstats
path: root/community/chatty/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/chatty/APKBUILD')
-rw-r--r--community/chatty/APKBUILD65
1 files changed, 52 insertions, 13 deletions
diff --git a/community/chatty/APKBUILD b/community/chatty/APKBUILD
index 90e1288a981..6afc3ea8f31 100644
--- a/community/chatty/APKBUILD
+++ b/community/chatty/APKBUILD
@@ -1,35 +1,74 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Contributor: Danct12 <danct12@disroot.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Mike Banon <mikebdp2@gmail.com>
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=chatty
-pkgver=0.3.0
+pkgver=0.8.2
pkgrel=0
-pkgdesc="A phone dialer and call handler"
-arch="all !s390x !mips !mips64" # Blocked by libhandy and evolution
+_libcmatrix=702b894675f12ecd43439b3b3eee66cc74899b82
+_libgd=c7c7ff4e05d3fe82854219091cf116cce6b19de0
+pkgdesc="XMPP and SMS messaging via libpurple and Modemmanager"
+# s390x: doubt anyone would use a mainframe for texting
+arch="all !s390x"
url="https://source.puri.sm/Librem5/chatty"
license="GPL-3.0-or-later"
depends="
cyrus-sasl
- libpurple-xmpp
+ purple-xmpp
+ mmsd-tng
purple-carbons
purple-lurch
- purple-mm-sms
purple-xmpp-http-upload
"
-makedepends="meson ninja gtk+3.0-dev pidgin-dev libhandy1-dev evolution-dev
- evolution-data-server-dev libgee-dev folks-dev feedbackd-dev libphonenumber-dev olm-dev"
+makedepends="
+ evolution-data-server-dev
+ evolution-dev
+ feedbackd-dev
+ folks-dev
+ gspell-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ libgee-dev
+ libphonenumber-dev
+ meson
+ modemmanager-dev
+ olm-dev
+ pidgin-dev
+ "
checkdepends="appstream-glib desktop-file-utils"
-source="https://source.puri.sm/Librem5/chatty/-/archive/v$pkgver/chatty-v$pkgver.tar.gz"
+source="https://gitlab.gnome.org/World/Chatty/-/archive/v$pkgver/Chatty-v$pkgver.tar.gz
+ https://source.puri.sm/Librem5/libcmatrix/-/archive/$_libcmatrix/libcmatrix-$_libcmatrix.tar.gz
+ https://gitlab.gnome.org/GNOME/libgd/-/archive/$_libgd/libgd-$_libgd.tar.gz
+ "
+
subpackages="$pkgname-lang $pkgname-bash-completion $pkgname-dbg"
options="!check" # Requires running Wayland compositor
-builddir="$srcdir/$pkgname-v$pkgver"
+builddir="$srcdir/Chatty-v$pkgver"
+
+prepare() {
+ rm -rf "$builddir"/subprojects/libgd
+ rm -rf "$builddir"/subprojects/libcmatrix
+ mv "$srcdir"/libgd-$_libgd "$builddir"/subprojects/libgd
+ mv "$srcdir"/libcmatrix-$_libcmatrix "$builddir"/subprojects/libcmatrix
+
+ default_prepare
+}
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="76a66ae890c528e829fa53bb15fd43a34c062f2c7283ff133d5ea39819f11947d1f6b405c548f2dae59593ea9b9cac1adf8828bd267cb2c2b14b159fd6c3b524 chatty-v0.3.0.tar.gz"
+
+sha512sums="
+5422fb413d7ccaa0012daa61d227f26a6f1addc48934750b82b7a269439f1219a1794c52df95a2e9f564327b62cb64fc09afa994140913920dd32e6dccf27e1d Chatty-v0.8.2.tar.gz
+9fc66c3f5115c54af76cf90f191c4b7dd78d22ba160feadefefa32590deea01a51aa670fa34b1f849de35dbf95ab4a4c0dc2160db827636e89bd7a2e22b0a188 libcmatrix-702b894675f12ecd43439b3b3eee66cc74899b82.tar.gz
+681cc23b5a33df88a92e3aac33d0dba1c6ebb69a2bd6f15b6ae31f0b444c108f7bfd1391e604433be58d82c0032028b112652d3d0c473abe4db02d66c55cdef3 libgd-c7c7ff4e05d3fe82854219091cf116cce6b19de0.tar.gz
+"