aboutsummaryrefslogtreecommitdiffstats
path: root/community/check_postgres/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/check_postgres/APKBUILD')
-rw-r--r--community/check_postgres/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/community/check_postgres/APKBUILD b/community/check_postgres/APKBUILD
index f6338a736f5..3b33cdb30e9 100644
--- a/community/check_postgres/APKBUILD
+++ b/community/check_postgres/APKBUILD
@@ -3,16 +3,16 @@
# Maintainer: G.J.R. Timmer <gjr.timmer@gmail.com>
# TODO: run tests!
pkgname=check_postgres
-pkgver=2.25.0
-pkgrel=1
+pkgver=2.26.0
+pkgrel=0
pkgdesc="PostgreSQL monitoring script"
-url="https://bucardo.org/wiki/Check_postgres"
+url="https://bucardo.org/check_postgres/"
arch="noarch"
license="BSD-2-Clause"
-depends="postgresql perl"
-makedepends="perl-dev"
+depends="postgresql perl-dbd-pg"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/bucardo/check_postgres/archive/$pkgver.tar.gz"
+options="!check" # failing tests
build() {
perl Makefile.PL \
@@ -24,6 +24,10 @@ build() {
make
}
+check() {
+ make test
+}
+
package() {
make DESTDIR="$pkgdir" install
@@ -31,4 +35,6 @@ package() {
mv "$pkgdir"/usr/bin/check_postgres.pl "$pkgdir"/usr/bin/check_postgres
}
-sha512sums="ab7d4b231f1428f549a2da0370de63c39d54287f8284c65044d1aa8fed120d89e9730c3b614004fdc298536402330ccac43d2d9dfe8b20cc5aff6f89f7be0915 check_postgres-2.25.0.tar.gz"
+sha512sums="
+020a765cdf47ae5a76a5de80cfcd196f2ac476ee931bf42a6cb6eaab39ae2a729f7eac0c14d3e13cca443fdc48806043faad9c55bb84c9f4469d502b80e470cb check_postgres-2.26.0.tar.gz
+"