aboutsummaryrefslogtreecommitdiffstats
path: root/community/cheese/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cheese/APKBUILD')
-rw-r--r--community/cheese/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/community/cheese/APKBUILD b/community/cheese/APKBUILD
index c40c60ddfd0..aee0bb934d9 100644
--- a/community/cheese/APKBUILD
+++ b/community/cheese/APKBUILD
@@ -1,13 +1,14 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer:
pkgname=cheese
-pkgver=3.38.0
+pkgver=44.1
pkgrel=1
pkgdesc="Take photos and videos with your webcam"
url="https://wiki.gnome.org/Apps/Cheese"
# s390x blocked by gnome-desktop
arch="all !s390x"
license="GPL-2.0-or-later"
+options="!check" # no testsuite
depends="gsettings-desktop-schemas"
makedepends="
clutter-dev
@@ -31,19 +32,24 @@ makedepends="
vala
"
checkdepends="xvfb-run"
-options="!check" # wonky tests
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
-source="https://download.gnome.org/sources/cheese/${pkgver%.*}/cheese-$pkgver.tar.xz
- 7cf6268e54620bbbe5e6e61800c50fb0cb4bea57.patch"
+source="https://download.gnome.org/sources/cheese/${pkgver%.*}/cheese-$pkgver.tar.xz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="210b50fc79a7b3a72c94163fe0dd76f7f29f576c1085c671c2c6c3b7f59ee362aec288f885a590ebfd9530534b6a6bad569c6df57874b9fcecf7e9f1ba9531ae cheese-3.38.0.tar.xz
-de93e2664331a792205c29cf893317719b182bece4185452e705cc349d48dbe46d7320a337e16d923dee4da693c07ba0542b4bc4367162212c7df549313849c2 7cf6268e54620bbbe5e6e61800c50fb0cb4bea57.patch"
+sha512sums="
+106f02c0bd6e21039e3d1cdbcb8111c8d76638666b3a3ee65bc81295deaf50acf49023f3f7bf2ca244a9b7f4ac95d04fbc5864c1ded8698c52665c23c3640dc1 cheese-44.1.tar.xz
+"