aboutsummaryrefslogtreecommitdiffstats
path: root/community/chntpw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/chntpw/APKBUILD')
-rw-r--r--community/chntpw/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/community/chntpw/APKBUILD b/community/chntpw/APKBUILD
index dfb11a891b7..207cc79637d 100644
--- a/community/chntpw/APKBUILD
+++ b/community/chntpw/APKBUILD
@@ -2,13 +2,12 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=chntpw
pkgver=140201
-pkgrel=3
+pkgrel=5
pkgdesc="Change passwords in Windows SAM files"
url="http://pogostick.net/~pnh/ntpasswd/"
arch="all"
options="!check"
license="GPL-2.0"
-makedepends=""
source="http://pogostick.net/~pnh/ntpasswd/$pkgname-source-$pkgver.zip
stdint.patch
chntpw-080526-correct-test-for-failing-open-syscall.patch
@@ -17,16 +16,13 @@ source="http://pogostick.net/~pnh/ntpasswd/$pkgname-source-$pkgver.zip
chntpw-110511-robustness.patch
chntpw-140201-get_abs_path.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
make CC="${CC:-gcc}" CFLAGS="$CFLAGS" \
chntpw cpnt reged
}
package() {
- cd "$builddir"
install -d "$pkgdir"/usr/bin
install chntpw cpnt reged "$pkgdir"/usr/bin/
}