aboutsummaryrefslogtreecommitdiffstats
path: root/community/chromium/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/chromium/APKBUILD')
-rw-r--r--community/chromium/APKBUILD485
1 files changed, 266 insertions, 219 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index cb258dc296e..27f3e7dc919 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -1,30 +1,53 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Elly Fong-Jones <elly@elly.town>
+# Maintainer: lauren n. liberda <lauren@selfisekai.rocks>
pkgname=chromium
-pkgver=104.0.5112.79
-pkgrel=0
+pkgver=124.0.6367.60
+pkgrel=2
+_copium_tag=124.5
+# https://source.chromium.org/chromium/chromium/src/+/main:third_party/test_fonts/test_fonts.tar.gz.sha1
+# (for the given version, when it changes)
+_testfonts=336e775eec536b2d785cc80eff6ac39051931286
pkgdesc="Chromium web browser"
url="https://www.chromium.org/Home"
-arch="aarch64 x86_64" # x86: ./v8_context_snapshot_generator segfaults
+arch="aarch64 armv7 x86_64"
license="BSD-3-Clause"
+# explicit depends for --headless
+# XXX: eudev-libs replaced by so:libudev.so.1 to allow installation with libudev-zero
+# take care if libudev.so ever updates somajor..
+depends="
+ font-opensans
+ gtk+3.0
+ icu-data-full
+ mesa-dri-gallium
+ musl>=1.2.3_git20230322-r0
+ so:libudev.so.1
+ xdg-utils
+ "
makedepends="
alsa-lib-dev
bash
bison
bsd-compat-headers
+ brotli-dev
bzip2-dev
cairo-dev
clang-dev
compiler-rt
+ crc32c-dev
cups-dev
curl-dev
+ dav1d-dev
dbus-glib-dev
+ double-conversion-dev
elfutils
elfutils-dev
eudev-dev
ffmpeg-dev
findutils
flac-dev
+ flatbuffers-dev
flex
freetype-dev
gn
@@ -32,20 +55,21 @@ makedepends="
gtk+3.0-dev
gzip
harfbuzz-dev
+ highway-dev
hunspell-dev
- hwids-usb
- java-jdk
+ hwdata-dev
jpeg-dev
- jsoncpp-dev
krb5-dev
lcms2-dev
libbsd-dev
libcap-dev
+ libevdev-dev
libevent-dev
libexif-dev
+ libffi-dev
libgcrypt-dev
libjpeg-turbo-dev
- libpng-dev
+ libsecret-dev
libusb-dev
libva-dev
libwebp-dev
@@ -61,9 +85,9 @@ makedepends="
llvm
mesa-dev
minizip-dev
- ninja
- nodejs
+ nodejs-current
nss-dev
+ openh264-dev
opus-dev
pciutils-dev
perl
@@ -71,70 +95,94 @@ makedepends="
pulseaudio-dev
py3-setuptools
python3
- re2-dev
- snappy-dev
+ qt5-qtbase-dev
+ rust
+ samurai
speex-dev
sqlite-dev
xcb-proto
- xdg-utils
zlib-dev
+ zstd-dev
"
-# explicit depends for --headless
-# XXX: eudev-libs replaced by so:libudev.so.1 to allow installation with libudev-zero
-# take care if libudev.so ever updates somajor..
-depends="xdg-utils so:libudev.so.1 gtk+3.0 font-opensans"
-options="suid !check" # broken
+checkdepends="py3-six"
subpackages="
- $pkgname-dbg
+ $pkgname-qt5
$pkgname-chromedriver
$pkgname-doc
$pkgname-lang
$pkgname-swiftshader
"
source="https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
- test_fonts-cd96fc55dc243f6c6f4cb63ad117cad6cd48dceb.tar.gz::https://chromium-fonts.storage.googleapis.com/cd96fc55dc243f6c6f4cb63ad117cad6cd48dceb
+ https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver-testdata.tar.xz
+ test_fonts-$_testfonts.tar.gz::https://chromium-fonts.storage.googleapis.com/$_testfonts
+ copium-$_copium_tag.tar.gz::https://codeberg.org/selfisekai/copium/archive/$_copium_tag.tar.gz
chromium-launcher.sh
chromium.conf
google-api.keys
- canonicalize-file-name.patch
- chromium-104-ContentRendererClient-type.patch
- chromium-VirtualCursor-standard-layout.patch
chromium-revert-drop-of-system-java.patch
- chromium-use-alpine-target.patch
- credentials-sys-types-header.patch
- default-pthread-stacksize.patch
- dns-resolver.patch
- fix-crashpad.patch
+ compiler.patch
+ disable-dns_config_service.patch
+ disable-failing-tests.patch
+ fc-cache-version.patch
fix-missing-cstdint-include-musl.patch
- fix-narrowing-cast.patch
+ fix-opus.patch
+ fstatat-32bit.patch
gdbinit.patch
- lto-core-count.patch
- memory-tagging-arm64.patch
+ generic-sensor-include.patch
+ import-version.patch
+ libstdc++13.patch
+ mman.patch
+ musl-auxv.patch
musl-sandbox.patch
musl-tid-caching.patch
musl-v8-monotonic-pthread-cont_timedwait.patch
no-execinfo.patch
- no-glibc-version.patch
no-mallinfo.patch
no-res-ninit-nclose.patch
- no-stat-redefine.patch
- partition-atfork.patch
- push-back-nullptr.patch
- quiche-arena-size.patch
- remove-no-opaque-pointers-flag.patch
- roll-src-third_party-ffmpeg.patch
- scoped-file-no-close.patch
- system-zlib.patch
+ no-sandbox-settls.patch
+ partalloc-no-tagging-arm64.patch
+ perfetto-libstdc++.patch
+ pvalloc.patch
+ random-fixes.patch
+ quiche-array.patch
+ system-zstd.patch
temp-failure-retry.patch
- wtf-stacksize.patch
- x11-ozone-fix-X11-screensaver-suspension.patch
-"
+ yes-musl.patch
+ "
+_copium_patches="
+ cr124-iwyu-sys-select-dawn-terminal.patch
+ cr124-libwebp-shim-sharpyuv.patch
+ "
+# chrome-sandbox can use suid when user namespaces aren't available, but uses only userns and drops privileges normally
+options="suid"
# backwards compat (merged into primary)
provides="$pkgname-angle=$pkgver-r$pkgrel"
+case "$CARCH" in
+riscv64)
+ ;;
+*)
+ # dbg outside riscv only
+ subpackages="$pkgname-dbg $subpackages"
+ ;;
+esac
+
+case "$CARCH" in
+x86_64)
+ ;;
+*)
+ # 32-bit fails a bunch of tests for various size-related reasons
+ # aarch64 gets timeout related failures due to builder setup, no easy way to
+ # raise timeouts
+ options="$options !check"
+ ;;
+esac
+
# secfixes:
+# 116.0.5845.187-r0:
+# - CVE-2023-4863
# 103.0.5060.134-r0:
# - CVE-2022-2163
# - CVE-2022-2477
@@ -448,7 +496,21 @@ upstream_version() {
prepare() {
default_prepare
- cd "$srcdir"/"chromium-$pkgver"
+ for i in $_copium_patches; do
+ case "$i" in
+ *.patch)
+ msg "${i%::*}"
+ patch -p1 -i "$srcdir/copium/$i" || failed="$failed $i"
+ ;;
+ esac
+ done
+ if [ ! -z "$failed" ]; then
+ error "The following patches failed to apply:"
+ for i in $failed; do
+ printf " %s\n" "$i" >&2
+ done
+ exit 1
+ fi
mv ../test_fonts/ ./third_party/test_fonts/
@@ -462,28 +524,40 @@ prepare() {
ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/
# reusable system library settings
+ # libavif - https://github.com/AOMediaCodec/libavif/commit/50a541469c98009016af8dcc9f83a1be79f3a7d9
+ # libaom - https://aomedia.googlesource.com/aom/+/706ee36dcc82%5E%21/
+ # but watch this space: https://aomedia-review.googlesource.com/c/aom/+/188606
+ # jsoncpp, re2, snappy, swiftshader, woff2 - needs use_custom_libcxx=false
local use_system="
+ brotli
+ crc32c
+ dav1d
+ double-conversion
ffmpeg
flac
+ flatbuffers
fontconfig
freetype
harfbuzz-ng
+ highway
icu
libdrm
libevent
libjpeg
- libpng
+ libsecret
+ libusb
libwebp
libxml
libxslt
+ openh264
opus
- re2
- snappy
zlib
+ zstd
"
+
for _lib in $use_system libjpeg_turbo; do
msg "Removing buildscripts for system provided $_lib"
- find . -type f -path "*third_party/$_lib/*" \
+ find . -type f -path "*third_party/$_lib/*" \
\! -path "*third_party/$_lib/chromium/*" \
\! -path "*third_party/$_lib/google/*" \
\! -path './base/third_party/icu/*' \
@@ -514,11 +588,13 @@ prepare() {
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/*.cc \
third_party/maldoca/src/maldoca/ole/oss_utils.h
+
+ _configure
}
-_buildtype=Release
+_configure() {
+ cd "$builddir"
-build() {
##############################################################
# Please dont use these keys outside of Alpine Linux project #
# You can create your own at: #
@@ -527,11 +603,15 @@ build() {
local _google_api_key _google_default_client_id _google_default_client_secret
eval "$(base64 -d < $srcdir/google-api.keys)"
- # silence really annoying warning on every compiler invocation, reproducible extras
- export CFLAGS="${CFLAGS/-g/} -O2 -Wno-unknown-warning-option -Wno-builtin-macro-redefined"
- export CXXFLAGS="${CXXFLAGS/-g/} -O2 -Wno-unknown-warning-option -Wno-builtin-macro-redefined"
+ export CFLAGS="${CFLAGS/-g/} -O2 -Wno-unknown-warning-option -Wno-builtin-macro-redefined -Wno-deprecated-declarations -Wno-shift-count-overflow -Wno-ignored-attributes"
+ export CXXFLAGS="${CXXFLAGS/-g/} -O2 -Wno-unknown-warning-option -Wno-builtin-macro-redefined -Wno-deprecated-declarations -Wno-invalid-constexpr"
export CPPFLAGS="${CPPFLAGS/-g/} -D__DATE__= -D__TIME__= -D__TIMESTAMP__="
+ # breaks chromium
+ export CXXFLAGS="${CXXFLAGS/-D_GLIBCXX_ASSERTIONS=1}"
+ export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection}"
+ export CFLAGS="${CFLAGS/-fstack-clash-protection}"
+
export AR="llvm-ar"
export CC="clang"
export CXX="clang++"
@@ -542,15 +622,51 @@ build() {
# this should be at 0 for -dbg too. change it for local debugging only
local symbol_level=0
+ case "$CARCH" in
+ riscv64)
+ # no vaapi on riscv support
+ local vaapi=false
+ ;;
+ *)
+ local vaapi=true
+ ;;
+ esac
+
+ case "$CARCH" in
+ armv7)
+ local maglev=false
+ ;;
+ *)
+ local maglev=true
+ ;;
+ esac
+
+ local clang_ver="$(clang -dumpversion)"
+
+ case "$USE_CCACHE" in
+ 1)
+ local cc_wrapper="ccache"
+ ;;
+ *)
+ local cc_wrapper=""
+ ;;
+ esac
+
+ # shellcheck disable=2089
local gn_config="
blink_enable_generated_code_formatting=false
+ cc_wrapper=\"$cc_wrapper\"
chrome_pgo_phase=0
+ clang_base_path=\"/usr\"
clang_use_chrome_plugins=false
+ clang_version=\"${clang_ver%%.*}\"
custom_toolchain=\"//build/toolchain/linux/unbundle:default\"
disable_fieldtrial_testing_config=true
enable_hangout_services_extension=true
enable_nacl=false
+ enable_nocompile_tests=false
enable_stripping=false
+ enable_rust=true
enable_vr=false
fatal_linker_warnings=false
ffmpeg_branding=\"Chrome\"
@@ -558,172 +674,98 @@ build() {
google_default_client_id=\"$_google_default_client_id\"
google_default_client_secret=\"$_google_default_client_secret\"
host_toolchain=\"//build/toolchain/linux/unbundle:default\"
- icu_use_data_file=true
+ icu_use_data_file=false
is_cfi=false
+ is_clang=true
is_component_ffmpeg=true
is_debug=false
is_official_build=true
link_pulseaudio=true
proprietary_codecs=true
+ regenerate_x11_protos=true
rtc_link_pipewire=true
rtc_use_pipewire=true
+ rustc_version=\"yes\"
+ rust_sysroot_absolute=\"/usr\"
symbol_level=$symbol_level
treat_warnings_as_errors=false
- use_custom_libcxx=false
- use_gnome_keyring=false
+ use_custom_libcxx=true
+ use_lld=true
use_pulseaudio=true
+ use_safe_libstdcxx=false
+ use_system_libffi=true
use_sysroot=false
- use_system_freetype=true
- use_system_harfbuzz=true
- use_system_lcms2=true
- use_system_libdrm=true
- use_system_libjpeg=true
- use_system_libpng=true
- use_system_wayland_scanner=true
- use_system_zlib=true
- use_vaapi=true
- "
+ use_thin_lto=false
+ use_vaapi=$vaapi
+ v8_enable_maglev=$maglev
+ "
- gn gen out/$_buildtype \
- --args="$(echo $gn_config)" \
- --export-compile-commands
+ # shellcheck disable=2090,2116
+ gn gen out/bld --args="$(echo $gn_config)"
+}
+build() {
msg "Ninja turtles GO!"
# final link needs lots of file descriptors
ulimit -n 4096
- ninja -C out/$_buildtype \
+ # moc and friends not in path by default
+ export PATH="$PATH:/usr/lib/qt5/bin"
+
+ # shellcheck disable=2046
+ ninja -C out/bld \
chrome \
chrome_sandbox \
chromedriver.unstripped \
- chrome_crashpad_handler
-
- if [ -n "$CHECK" ]; then
- ninja -C out/$_buildtype \
- base_unittests \
- base_util_unittests \
- sandbox_linux_unittests \
- chromedriver_unittests \
- crypto_unittests \
- skia_unittests \
- blink_common_unittests \
- ozone_unittests \
- ozone_x11_unittests \
- ozone_gl_unittests \
- absl_hardening_tests \
- # angle_unittests \
- blink_heap_unittests \
- # blink_platform_unittests \
- boringssl_crypto_tests \
- boringssl_ssl_tests \
- cast_unittests \
- capture_unittests \
- # components_browsertests \
- # components_unittests \
- # content_browsertests \
- # content_unittests \
- # crashpad_tests \
- events_unittests \
- gcm_unit_tests \
- gin_unittests \
- google_apis_unittests \
- gpu_unittests \
- gwp_asan_unittests \
- ipc_tests \
- jingle_unittests \
- latency_unittests \
- libjingle_xmpp_unittests \
- liburlpattern_unittests \
- media_blink_unittests \
- media_unittests \
- midi_unittests \
- mojo_unittests \
- net_unittests \
- # cc_unittests \
- # blink_unittests \
- perfetto_unittests \
- # services_unittests \
- shell_dialogs_unittests \
- sql_unittests \
- storage_unittests \
- ui_base_unittests \
- ui_touch_selection_unittests \
- url_unittests \
- # webkit_unit_tests \
- wtf_unittests \
- zlib_unittests
- fi
+ chrome_crashpad_handler \
+ $(want_check && echo base_unittests)
+
+}
+
+check_base_unittests() {
+ # TODO: fix these tests, hopefully
+ # https://issues.chromium.org/issues/40939315
+ broken="MessagePumpLibeventTest.NestedNotification*"
+ broken="$broken:AlternateTestParams/PartitionAllocTest.SchedulerLoopQuarantine"
+ broken="$broken:ClampTest.Death"
+ broken="$broken:OptionalTest.DereferencingNoValueCrashes"
+ broken="$broken:RawPtrTest.TrivialRelocability"
+ broken="$broken:SafeNumerics.IntMaxOperations"
+ broken="$broken:StringPieceTest.InvalidLengthDeath"
+ broken="$broken:StringPieceTest.OutOfBoundsDeath"
+ # test-launcher-bot-mode enables parallelism and uncolored output
+ ./out/bld/base_unittests --test-launcher-bot-mode --gtest_filter="-$broken"
}
check() {
- out/$_buildtype/base_unittests
- out/$_buildtype/base_util_unittests
- out/$_buildtype/sandbox_linux_unittests # broken + does not compile
- out/$_buildtype/chromedriver_unittests
- out/$_buildtype/crypto_unittests
- out/$_buildtype/skia_unittests
- out/$_buildtype/ozone_unittests
- out/$_buildtype/ozone_x11_unittests # ?
- out/$_buildtype/ozone_gl_unittests # broken
- out/$_buildtype/absl_hardening_tests
- # out/$_buildtype/angle_unittests # broken / does not compile
- out/$_buildtype/blink_common_unittests
- out/$_buildtype/blink_heap_unittests
- # out/$_buildtype/blink_platform_unittests # broken / does not compile
- out/$_buildtype/boringssl_crypto_tests
- out/$_buildtype/boringssl_ssl_tests
- out/$_buildtype/cast_unittests
- out/$_buildtype/capture_unittests --gtest_filter=-*UsingRealWebcam* # broken
- # out/$_buildtype/components_browsertests # broken / does not compile
- # out/$_buildtype/components_unittests # broken / does not compile
- # out/$_buildtype/content_browsertests # broken / does not compile
- # out/$_buildtype/content_unittests # broken / does not compile
- # out/$_buildtype/crashpad_tests # broken / does not compile
- out/$_buildtype/events_unittests
- out/$_buildtype/gcm_unit_tests
- out/$_buildtype/gin_unittests # ?
- out/$_buildtype/google_apis_unittests
- out/$_buildtype/gpu_unittests
- out/$_buildtype/gwp_asan_unittests # broken / required?
- out/$_buildtype/ipc_tests
- out/$_buildtype/jingle_unittests
- out/$_buildtype/latency_unittests
- out/$_buildtype/libjingle_xmpp_unittests
- out/$_buildtype/liburlpattern_unittests
- out/$_buildtype/media_blink_unittests # broken
- out/$_buildtype/media_unittests # broken
- out/$_buildtype/midi_unittests
- out/$_buildtype/mojo_unittests
- out/$_buildtype/net_unittests # broken
- # out/$_buildtype/cc_unittests # broken / does not compile
- # out/$_buildtype/blink_unittests # broken / does not compile
- out/$_buildtype/perfetto_unittests # ?
- # out/$_buildtype/services_unittests # broken / does not compile
- out/$_buildtype/shell_dialogs_unittests
- out/$_buildtype/sql_unittests
- out/$_buildtype/storage_unittests
- out/$_buildtype/ui_base_unittests # ok
- out/$_buildtype/ui_touch_selection_unittests
- out/$_buildtype/url_unittests
- # out/$_buildtype/webkit_unit_tests # broken / does not compile
- out/$_buildtype/wtf_unittests
- out/$_buildtype/zlib_unittests
+ # vpython3 execs system python3 with this set
+ export VPYTHON_BYPASS="manually managed python not supported by chrome operations"
+ # for vpython3 in cwd
+ export PATH="$PATH:$PWD/third_party/depot_tools"
+
+ check_base_unittests
+
}
package() {
- cd "$builddir"/out/$_buildtype
+ cd ./out/bld
mkdir -p "$pkgdir"/usr/bin
# binaries
- install -Dm755 chrome -t "$pkgdir"/usr/lib/$pkgname/
+ install -Dm755 chrome "$pkgdir"/usr/lib/$pkgname/chromium
+ # backward compat symlink
+ ln -sfv chromium "$pkgdir"/usr/lib/$pkgname/chrome
install -Dm4755 chrome_sandbox "$pkgdir"/usr/lib/$pkgname/chrome-sandbox
install -Dm755 chrome_crashpad_handler -t "$pkgdir"/usr/lib/$pkgname/
+ # qt5
+ install -Dm755 libqt5_shim.so -t "$pkgdir"/usr/lib/$pkgname/
+
# chromedriver
install -Dm755 chromedriver.unstripped "$pkgdir"/usr/lib/$pkgname/chromedriver
- ln -sf /usr/lib/$pkgname/chromedriver "$pkgdir"/usr/bin/chromedriver
+ ln -sfv ../lib/$pkgname/chromedriver "$pkgdir"/usr/bin/chromedriver
# resources
install -Dm644 snapshot_blob.bin -t "$pkgdir"/usr/lib/$pkgname/
@@ -749,8 +791,8 @@ package() {
# It is important that we name the target "chromium-browser",
# xdg-utils expect it; bug https://bugs.gentoo.org/355517
- mkdir -p "$pkgdir"/usr/bin
- ln -sf /usr/lib/$pkgname/chromium-launcher.sh "$pkgdir"/usr/bin/chromium-browser
+ ln -sfv ../lib/$pkgname/chromium-launcher.sh "$pkgdir"/usr/bin/chromium-browser
+ ln -sfv chromium-browser "$pkgdir"/usr/bin/chromium
install -Dm644 "$srcdir"/chromium.conf \
-t "$pkgdir"/etc/chromium/
@@ -798,6 +840,12 @@ package() {
"$pkgdir"/usr/share/metainfo/chromium.appdata.xml
}
+qt5() {
+ pkgdesc="chromium qt5 shim"
+
+ amove usr/lib/$pkgname/libqt5_shim.so
+}
+
chromedriver() {
pkgdesc="WebDriver driver for the Chromium Browser"
depends="$pkgname=$pkgver-r$pkgrel"
@@ -827,41 +875,40 @@ swiftshader() {
}
sha512sums="
-3c6814c6670ccb938a4d2502f36e89ba5ddec9ffdc7c201111054edad5f54a31a93d9fb34c2c04265788ea6f7a8f4391aa0878a0820eac45674a69eba443480d chromium-104.0.5112.79.tar.xz
-f554ccc5d8a5c066634357878c89944cc591809ea6f6c6ef5b35e970e9674e0b3be8fddb06c0d333ddc65211fa09ae5e0b4b483ca70048156c29607c5487c017 test_fonts-cd96fc55dc243f6c6f4cb63ad117cad6cd48dceb.tar.gz
-b9a810416dd7a8ffc3a5ced85ad9acebda1665bd08a57eec7b189698cc5f74d2c3fd69044e20fcb83297a43214b2772a1312b2c6122ea0eb716abacf39524d60 chromium-launcher.sh
+3c13cbd65b11d187576dbf40665b4e43397e706fe43516dd280ad238519aa663c490a314ff43a1f2b41c1f757e3d9dbeeefe88e2d0cf312bb149c7737d8713fd chromium-124.0.6367.60.tar.xz
+6837910f964f337cb7d43a4482dcebe707957940f037cbc368133df6ba23207dab0061d28f120cdbc9f9fb992c6256cff8e92638f767c3bc36323fbcbf10aa17 chromium-124.0.6367.60-testdata.tar.xz
+bbc928e99ebcd4d953b982688b01526cb754bad018f67be9e777a4f8ac51cdd3e01374e5a63faf55b12e7cee0d52816c88062e012b5bcc4f9bb41f28d8e0b7f7 test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz
+13c647dc2024e27ae8a4d7e8f1202037a342f4a7054477226665c332029e1b6f1d8b99004c2b2809bcf1e6c19b1359ef5e1c971552d7ced59c5b43d5a836af88 copium-124.5.tar.gz
+1b16564f85a03f3eb934ec51289dc6159e2454202d40f48354f947d6ceffac8889e9eb4c0f4dfaafb3a15101566d54039f832bc9a8433c3c463e2d1dac2d2acc chromium-launcher.sh
9cfcb41d69c5a515b6f9fe2a629579fa499e1f48eb58a0ce4ec8e5029d450bcafb6d963019aaac9a6838244bee9f9ba7fe5ef6146a0ca6b20fcda4ab7f059476 chromium.conf
2d8237a940ea691bd10b08315429677a587f7ef9692a0cca53bfd066eae82998a6c71f402a8669e9de39f94d7f3280745d1628ea6eac5d76ca7116844d4e0dac google-api.keys
-252b37a2ecc5e7a25385943045f426dc2e30991b28d206ceaff1be7fd8ffeeb024310a8fca6b3e69a4b1c57db535d51c570935351053525f393682d5ecd0f9a9 canonicalize-file-name.patch
-c2e8c18ceb78c9f62a1ab93bfb566dffee413f9f79846a771294b87e3add9a93cf804ca830a3e3e3b0343689b70c46063c85acb4aaf9ca31a4d33059c98f3f95 chromium-104-ContentRendererClient-type.patch
-ac0a80174f95d733f33ddc06fc88cdcf7db0973378c28d8544dc9c19e2dabeac47f91c99b3e7384f650b3405554a9e222543f0860b6acc407c078a8c9180d727 chromium-VirtualCursor-standard-layout.patch
-c4654d5b23c6f5d9502507e534fe1951d6749c62251e49b6adfe10d1569431e7f7a5a6fa5ff09ec30984415ced27a5e20985df8c91295de34af3c84557fa5b91 chromium-revert-drop-of-system-java.patch
-6add8b4c293f5392748a2eec9486cb4a6534e161977c6a98de71617b9abcdd1e8ad94b44014256a4b52e33eb9dd4aca380279d4161629a1bb2d7b15f8eb5b459 chromium-use-alpine-target.patch
-274858323d040ac8c51bac90b6ef91bb075d7b8d92d73952ed700c10a8bae2c2115fb2a9cc6912de79be226c141d7106839fc3486e22c0206e75cb6d8ff65ee6 credentials-sys-types-header.patch
-22da17c649ae9845d6a174187f2b666245a10db8a997169fc214c430fbba10143cfb57f8f6ece5acf856cd9ea09f293a1aca90cdf3e64fd9423b78beac53f517 default-pthread-stacksize.patch
-cd7719c30518aeb659e9b7dc126241f897afe1a231e601271b63ba170e811a93b514c4d2a77680cdf0c846f81fa6db766ac619aa200efb32cbdfff6732a63893 dns-resolver.patch
-9d1edb1e0624ee61825e3af23fbb8c5dbc09d2b92d7769d19f8ca618edae8de8a3e051fedf4ad92c230e1373dc8495922c46971aef93a580c04ad80bc33516c0 fix-crashpad.patch
-8bebf4a9d5225c6e47edc5b07c4b97be24a45cc221f49632836915ceeb4ecb69b7f79a31ea7f82171cde3443f45fec541f409892542cf1014e81aa6acd01566d fix-missing-cstdint-include-musl.patch
-efe97b9dd2ec5965fa0cdf1b2a3c01253835c2df710da7ea105c4ce008c11f9caaf8b4321736a2b91f06d8d61972c08e225b16509dc05176a2c39337688ad5b9 fix-narrowing-cast.patch
-82f2bd4aa613e792d3af6e7a8632e0920cf48504a7572fb97d5480ea182fa125fe526e7df1ce4311b5d139a3f78da0f0b54605fbd09d7cd43135906a7639e47f gdbinit.patch
-1e004d2390a8031125345d39a98e03aab7fa5120317b632cfb250f705bd2983292f41e9c29637b2ea284d095b5747ac2d9664bf0a309e13967283b505f134a29 lto-core-count.patch
-63e5b25c49af484964b3ac723da1c2f348812572a2e24ad412d2fb9eb7eec9ddc0e76568e76d1f352cdc562bc5003c93e04ee519a82e8568f48484d1682e237f memory-tagging-arm64.patch
-af7f8408a5125e2fd75372fcd9d6b355c96b97e1003e48634e54115b4e612c6f6d8d3a3c18d9a114363b6934e728aec1b94e93c8a2772785f88a83bbc7f42488 musl-sandbox.patch
-a018cf58b9e34f73d588961f2f9a36de67267060fb2e77ebc562974c6c92a59009161e374cf9bbdc35e8bf1a7e90f0b90117a0d494dcd2e2bb2f5e6534925d0b musl-tid-caching.patch
-556cc2ba28184a75745f13c673605327f5be590be179eb3f941dc0abded854a814e5da1432a28fb8d4dcdcd66ffd4c94ee1a8824d2cd93b632f48e9310dbc3fa musl-v8-monotonic-pthread-cont_timedwait.patch
-3f90f888f015efd04636eee0e8431d41e073d432563553298d7b8be7650c397eb7d43a5bf682df1f66ffd7182852d4b836adb7dcd934f9b45247cdd99046e45c no-execinfo.patch
-caf9c4e4533b94dfe6b28350f8ea9654311b684dfd0c5ba768ab14775e0164f577dfd356cd507bcad9f378ec2c180c8e6edbde9bba62caf70fbac5a642edc61b no-glibc-version.patch
-86a75fd53f5fc0c7a0b1ea73bbc0a6966464f613c8c410684cc25e5eee09482490aece8d2925bcece2489e1e3c1d70c659c6b6220119d7d546bf651864258a3e no-mallinfo.patch
-3319fa42bd582679f449151de5905c582e156cf8dff850326cfbd7a97c92afea0b074ff1275e1ec923ed1491db2adec632d4222fed0f7f1c6607aee930ec9559 no-res-ninit-nclose.patch
-0c0d3ed0a8f2bcecb2bf4eb56130fcd71031bb63744fb56e1b5a6b9dfbe16680607ff592e24602fe045b819509a70556e240b6fe0e876710977d60185f682df4 no-stat-redefine.patch
-ad563e29ac7d83c203f5af966c4ed3ebdeb5c997835a45fb28ecde08dde5231d0a775fb413f44867af28724504c42316b27d5a6aaa602057642dcbdf7ec20a7a partition-atfork.patch
-36f8b96a8143355b7855a248473206c16101616d46978773c8fad92757bb24f60f23d843a25c219efe4b0a957f43aa7ea5ce5867b29228ef7371d1b886e528da push-back-nullptr.patch
-d315ef36952f35f834742a063b11b312b3adc2b86fc34a73a6906652f4042e6537789aeae5aade3c60523a80eac8d9751eecac3716831b99a2f8725d4ce50df3 quiche-arena-size.patch
-bcf64dd4e15f455239d2784e52bb02ece04381ee5dd354462aba0f386293e7039766561f029c09cae943a815a02614103d9b87ea062d83b7dce60552174c56d2 remove-no-opaque-pointers-flag.patch
-128ec0fd14349e065c8bb0910d53cbea7423182a06e06f7b7765f3cba1e5ba5e7a8bccbcdab079335b5235abb7bf0d46dee21ecc8c221be7e1c5c6d9795f958e roll-src-third_party-ffmpeg.patch
-9c44875bcc5dd5431226568ba52d225f086b321325371d9e9e01d1fd892049e5aff324a89ba8268f32c59ce1a47e0b0d5448c9162a45ee5a60a58eecb69ca788 scoped-file-no-close.patch
-a88d3eee02709e3666adc103e67d4e09403904cf7d86193181b102a03cd8111a894394942f8564f04aab967df788d424f7ea5b649e03c65b8e654db936d9b49b system-zlib.patch
-ece751cd29d28772dd0955c84f5553a6858ac24d06ccb66ac75fcfc6b13460cf5c1f27392c094487e20e08e621d2099c3b5cc9a2a819a458e8c56c78fea11269 temp-failure-retry.patch
-1d4e8c6e65205e6b72af47b9a2fa6f96aaada9b7d5a74f4e11a345a885df3078b523d02aaf8e9dac3aa30d72bbbd07cd6dc7edcf44fb9ae57a7f81251c398f65 wtf-stacksize.patch
-e192f1e7a5383d60ad06f494b986d6a3e331c6098ec4aa23e313bf8c3fbbb1080873086f319b2e94bb32357bfb2192b39cc061ee017ae05b496c35de854f8010 x11-ozone-fix-X11-screensaver-suspension.patch
+29bb685e03356a77df5fd347cdf55194cc8b3265c421cc76e54d64edefc329dbcb052deb26b22e8f587ce68456876c071de1b7d258dd0fcc6ee66c875ec4a020 chromium-revert-drop-of-system-java.patch
+54eb147c0af2ba096d1df375a289b339ee855ab1a9114e7c747753f0274a6bafb7212c1859b7885454c4529d9a5e3bd9559fc14e8e006f23ccd381895fa68d15 compiler.patch
+4057cc78f10bfd64092bc35a373869abb1d68b880cdbca70422f39ffd78a929c19c7728d4d4c40709aaba25581148a93ae5343e724849fd35323062ed68753fa disable-dns_config_service.patch
+111bc22fb704d97759988268a40d6b356c51b0bd7a8119a694e905ffe21850ff64e91566cd0dd0c9d62fcb46dca8acc821436c34eb0ba78be872ee4f7ec88a7b disable-failing-tests.patch
+5fc5c012c1db6cf1ba82f38c6f3f4f5ca3a209e47ac708a74de379b018e0649b7694877c9571ef79002dde875ffc07b458a3355425f1c01867f362c66c2bc1bf fc-cache-version.patch
+9200f78bad70e95c648a5e8392d50642190600f655c6baa366ff6467ebad52d3b3f305dad58f3610da67136f4b723557653b174ec5c25be8d8737ee04d9ee09f fix-missing-cstdint-include-musl.patch
+b24563e9a738c00fce7ff2fbdee3d7c024d9125d7c74d9ab90af6bdb16f7ec8419f2c8aa78c0640f6d5d81c17dc2c673a194401d354f466749672729b48ed068 fix-opus.patch
+c63dee5044353eb306a39ca1526158c0f003ab310ecb03d1c368dc2a979454590c84b8d3c15484517d5e66bb8add9b231da9abbadf2e50850abd72ac1345c4ab fstatat-32bit.patch
+33ee60863cc438ef57ffef92ba4cf67a856a5ffc16138bce241bcf87e47b15154aa86918e793c26f7ec4dc62a445257ad5673ed7001daf22c4043cf6cc57da7f gdbinit.patch
+36a764fa73443b47d38050b52dbe6ad2fa8d67201ff4ccdbad13b52308ef165ca046aac6f9609fe35890a6485f0f3e672e78cc41e3e44f3cdc7f145e540524e8 generic-sensor-include.patch
+8de65109ece27ea63bd469f2220c56b8c752ba0a50fdf390082a2d5ae74b8e010199126175569f6d5084270dd4e0571e68aec32c0bca8211a6699925b3a09124 import-version.patch
+53721a222c099a96f01ef437ef132055ea4b624f6dc08e6c09c9fa1d6bb88bab23a3c0a3ee6871edb2fb88b86d9a48bb1d7a0acb84cdd3fca268832d83c9e11f libstdc++13.patch
+e75f57ae34c97ca1caf15fa4b4106c6c1e79c31ed66869cf92ed9ea0c449886c9511e455047c17c1e9ad8b9a46ad4948511a4f2995a4b6030fb4d1c7ae21d038 mman.patch
+99bcc7dd485b404a90c606a96addab1d900852128d44fb8cea8acc7303189ef87c89a7b0e749fd0e10c5ef5f6bf1fadeb5c16a34503cab6a59938ce2653d887e musl-auxv.patch
+50c274a420bb8a7f14fcb56e40920dac8f708792a4520789b4987facea459bef88113d5a2b60fa8c57bee6e92bff3617d6b73fa305c8c44614c638971cffd440 musl-sandbox.patch
+e7163ac5810ac85366cef2447412287c856e3d67c6b77f219a6e5a418b1965b98e449c409424ad0704a5bded9355dd0aec3dc4585918ce5a2ab36c079707afe2 musl-tid-caching.patch
+92eb002718026611f5542362ad69b67f0a398ff71b3fca5c05d55cb5c6f9f29334e5e127bb4860cfaa3fba0f0d4c901e2b98808217e7dc02e254a64a5c9521aa musl-v8-monotonic-pthread-cont_timedwait.patch
+73bca6c6f9873f2f11cef04f3f41f71e0ae86e7e2d77e14db4298675fec390744c5081f6fdb14052e5ee2b5885be1198c3aa6068eb2b656d1a665c0c3f36e708 no-execinfo.patch
+8e17101d69e23b456a9c03dc2fe95bcd56846389707ba6f4720192a9e9168406d20d9168dbebbb3a47d921ec92e478f0e390f46e6b9bb43a34dda217c6e6448b no-mallinfo.patch
+e4c4e5bc6f828f9c883dd418c0ba01887949c29c311f76206a1ec29f620b0c0ba0452949dc2778a9c46ea066405857536964a36436a68eecf7da7952736333cf no-res-ninit-nclose.patch
+6dc4d8dc92e685dace62265a1ddb3aebc558aed54d20ff6d36b030be0c48d7e84662326c31363612492574d9a03c62653cdc21a60995b97dee1d75cae86a9f9b no-sandbox-settls.patch
+d4ac7f350806b4410ccb1df3b0ad7e90a7b6d724a16919761aa2d47a6f21008c7374da528b05b754ee712b85d23adfb113c7f7b9ca2ed5b47644fe3ea0cb9119 partalloc-no-tagging-arm64.patch
+8e1aca983890c78d81a6f888b2cf1aa42878d1f8523e87d63b800e1e468cbfd33e5ff6a0975775ca222fe82f30c6497da95505da01b091c8776a44c98ac86f0f perfetto-libstdc++.patch
+2eb434b4fc6aee77026492644cd86772a543d9845f112a75cd4c3e1f25c9435cc31f8454c1c73223451fc9be69b86e822ff68821978f67f2fc8bcba50296d8e0 pvalloc.patch
+803b8117c65132f76bec42054a4b2257a078b15b07fd08645fec2dfd51aa4e0075a9015300cd579d4ae0d757d9850b9988e080cfc2eea093f6684fdf82c4722c random-fixes.patch
+86f612dd2b39602984a75b1b11c2ab8bc8cc6b4e78fae998570a777a6901ae45fdcdb22e46dd006dab703a0674e64c72cf8120af2dc5b9e78004f402c7e65358 quiche-array.patch
+b3beb98b539fe160fbc493ba410ae0f68540cc4b6834f1f8ce9a22c3f4f59ef5d583ad48793e10549fd02a701f833a3969791ef4524322cd1e715ca5bf226bc8 system-zstd.patch
+e48693e6b7aeebf69a5acbf80d9a35defe4c23835121dfeb58b051ac7c527e758a41004f4d193274fe1b01c0bfb1dbc77b09cb6a404a3fdee507a2918afb0edb temp-failure-retry.patch
+914ccf649d7771f19f209ab97f99c481aebc6f66174d68e8b539f6ad4a70bc8cb0fae2df6dadbf0415958ffb3574c420fe029079dcce45f5e5add4db2e903566 yes-musl.patch
"