aboutsummaryrefslogtreecommitdiffstats
path: root/community/claws-mail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/claws-mail/APKBUILD')
-rw-r--r--community/claws-mail/APKBUILD83
1 files changed, 41 insertions, 42 deletions
diff --git a/community/claws-mail/APKBUILD b/community/claws-mail/APKBUILD
index aaeb2d3c9cd..dc205c00868 100644
--- a/community/claws-mail/APKBUILD
+++ b/community/claws-mail/APKBUILD
@@ -1,13 +1,17 @@
# Contributor: Ɓukasz Jendrysik
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=claws-mail
-pkgver=4.0.0
-pkgrel=1
+pkgver=4.2.0
+pkgrel=0
pkgdesc="GTK+ based e-mail client"
url="https://www.claws-mail.org"
arch="all !x86" # spamassassin
license="GPL-3.0-or-later"
-subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-lang
+subpackages="
+ $pkgname-dbg
+ $pkgname-dev
+ $pkgname-doc
+ $pkgname-lang
$pkgname-plugins-acpi-notifier:_plugin
$pkgname-plugins-address-keeper:_plugin
$pkgname-plugins-archive:_plugin
@@ -30,28 +34,32 @@ subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-lang
$pkgname-plugins-dillo:_plugin
$pkgname-plugins-libravatar:_plugin
$pkgname-plugins-managesieve:_plugin
+ $pkgname-plugins-fancy:_plugin
"
-
-makedepends="gtk+3.0-dev startup-notification-dev enchant2-dev
- libgcrypt-dev libsm-dev gnutls-dev curl-dev dbus-glib-dev
- libetpan-dev openldap-dev gpgme-dev libsoup-dev perl-dev
- poppler-dev libarchive-dev libnotify-dev pinentry-gtk
- spamassassin libical-dev ytnef-dev bogofilter
- automake autoconf libtool
+makedepends="
+ bogofilter
+ curl-dev
+ dbus-glib-dev
+ enchant2-dev
+ gnutls-dev
+ gpgme-dev
+ gtk+3.0-dev
+ libarchive-dev
+ libetpan-dev
+ libgcrypt-dev
+ libical-dev
+ libnotify-dev
+ libsm-dev
+ openldap-dev
+ perl-dev
+ pinentry-gtk
+ poppler-dev
+ spamassassin
+ startup-notification-dev
+ webkit2gtk-4.1-dev
+ ytnef-dev
"
-case "$CARCH" in
- mips64|riscv64)
- _fancy_opt="--disable-fancy-plugin"
- ;;
- *) subpackages="$subpackages $pkgname-plugins-fancy:_plugin"
- makedepends="$makedepends webkit2gtk-dev"
- _fancy_opt="--enable-fancy-plugin"
- ;;
-esac
-
-depends="aspell-en"
source="https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.gz
- libetpan-1.9.4.patch
"
# secfixes:
@@ -60,13 +68,7 @@ source="https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver
# 3.17.6-r0:
# - CVE-2020-15917
-prepare() {
- default_prepare
- autoreconf -fi
-}
-
build() {
-
DATADIRNAME=share ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -81,7 +83,7 @@ build() {
--enable-bogofilter-plugin \
--enable-compface \
--enable-pdf_viewer-plugin \
- $_fancy_opt \
+ --enable-fancy-plugin \
--disable-jpilot \
--disable-bsfilter-plugin \
--disable-newmail-plugin
@@ -96,13 +98,12 @@ build() {
package() {
make DESTDIR="$pkgdir" install
- find tools -maxdepth 1 -type f -and -perm 111 -or -name '*.conf' | while read i; do
- install -D -m755 $i "$pkgdir"/usr/lib/claws-mail/tools/$i
- done
+ find tools -maxdepth 1 -type f -and \( -perm /u=x,g=x,o=x -or -name '*.conf' \) \
+ -exec install -D {} -t "$pkgdir"/usr/lib/claws-mail/tools/ \;
}
_plugin() {
- local _plugin=$(echo ${subpkgname#$pkgname-plugins-} | tr '-' '_'})
+ local _plugin=$(echo ${subpkgname#"$pkgname"-plugins-} | tr '-' '_'})
depends="claws-mail=$pkgver-r$pkgrel"
case "$_plugin" in
acpi_notifier)
@@ -135,17 +136,19 @@ _plugin() {
pkgdesc="Perl based extended filtering engine for Claws Mail";;
pgp)
pkgdesc="PGP plugin for signing and encrypting with Claws Mail"
- depends="$depends pinentry-gtk"
+ # TODO: Replace gnupg with specific gnupg subpackages that Claws Mail
+ # really needs.
+ depends="$depends pinentry-gtk gnupg"
;;
rssyl)
pkgdesc="RSS plugin for Claws Mail";;
smime)
pkgdesc="S/MIME support for Claws Mail"
- depends="$depends claws-mail-plugins-pgp"
+ depends="$depends claws-mail-plugins-pgp gpgsm"
;;
spamass)
pkgdesc="Spamassassin plugin for Claws Mail"
- depends= $depends "spamassassin"
+ depends="$depends spamassassin"
;;
spamreport)
pkgdesc="Report spam mail to various places with Claws Mail";;
@@ -163,13 +166,9 @@ _plugin() {
pkgdesc="Displays libravatar/gravatar profiles' images";;
esac
- mkdir -p "$subpkgdir"/usr/lib/claws-mail/plugins
- mv "$pkgdir"/usr/lib/claws-mail/plugins/${_plugin}* \
- "$subpkgdir"/usr/lib/claws-mail/plugins/
-
+ amove usr/lib/claws-mail/plugins/$_plugin*
}
sha512sums="
-9d6b07fdde3718085a42e5fda2434bc39eeb861aba28ea1bcb9086b12a1b1f8ecc146bfb58428546e28fef7c1c2fab630de0c4e51c275881e45d98dae6b9c778 claws-mail-4.0.0.tar.gz
-02d2402d9f63547089d97d7f24b2952271018ed358004e2c740c8c5b3b0f5083d8c5b0bf3f9e77ebcdaabcefce6d096b2aa89969b862c107fdf7a0ff19184c3b libetpan-1.9.4.patch
+a639d51703f1203223f1c94ed99a0bbe656aecb4aac5bfcff2acfc374e2c0c130f206f777c50979f3d3c2ae9e5aa62044a0553320e6607389044bab00cb106b0 claws-mail-4.2.0.tar.gz
"