aboutsummaryrefslogtreecommitdiffstats
path: root/community/clingo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/clingo/APKBUILD')
-rw-r--r--community/clingo/APKBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/community/clingo/APKBUILD b/community/clingo/APKBUILD
index 2e64a443b03..0b9dfe725b2 100644
--- a/community/clingo/APKBUILD
+++ b/community/clingo/APKBUILD
@@ -1,43 +1,39 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer:
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=clingo
-pkgver=5.5.0
-pkgrel=0
+pkgver=5.7.1
+pkgrel=1
pkgdesc="Grounder and solver for logic programs"
url="https://potassco.org/clingo/"
arch="all"
license="MIT"
depends="!clasp" # both provide /usr/bin/clasp
-makedepends="python3-dev cmake"
-subpackages="$pkgname-dev py3-$pkgname:py"
+makedepends="python3-dev cmake samurai"
+subpackages="$pkgname-dev $pkgname-libs py3-$pkgname:py"
options="!check"
source="https://github.com/potassco/clingo/archive/v$pkgver/clingo-$pkgver.tar.gz"
replaces="gringo" # backwards compatibility
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=None \
- -DCLINGO_REQUIRE_PYTHON=ON \
- -DCLINGO_BUILD_PY_SHARED=ON \
- -DPYCLINGO_USER_INSTALL=OFF \
- -DCLINGO_REQUIRE_LUA=OFF
- make -C build
+ -DCLINGO_BUILD_TESTS="$(want_check && echo ON || echo OFF)"
+ cmake --build build
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
py() {
pkgdesc="Python bindings for clingo"
depends="python3"
- mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+ amove usr/lib/python*
}
sha512sums="
-c5cc71be081f93bb1322ef018bf9eac024f872dc0f149b340370a40e4b0533b9345316ad259d7664a98fad4fab248e3decf535d393052971a3cd9cf6daa707c5 clingo-5.5.0.tar.gz
+e0903c06e45af0988887baa87b7ea455f74f639026508176f1c90be5ddc5db37b4d91bbb51ea542c944ebedc2c80f962bd0844fd8f226787cdc841785be99e30 clingo-5.7.1.tar.gz
"