aboutsummaryrefslogtreecommitdiffstats
path: root/community/clip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/clip/APKBUILD')
-rw-r--r--community/clip/APKBUILD35
1 files changed, 19 insertions, 16 deletions
diff --git a/community/clip/APKBUILD b/community/clip/APKBUILD
index bc5e0344e7d..c099d4b6a07 100644
--- a/community/clip/APKBUILD
+++ b/community/clip/APKBUILD
@@ -1,22 +1,22 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
pkgname=clip
-pkgver=2.0.0
-pkgrel=2
+pkgver=3.0.2
+pkgrel=0
pkgdesc="Video player and video collection manager"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by mauikit
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://invent.kde.org/maui/clip"
license="GPL-3.0-or-later"
-depends="
- mauikit
- qt5-qtbase-sqlite
- "
+depends="qt5-qtbase-sqlite"
makedepends="
extra-cmake-modules
- kcoreaddons-dev
- ki18n-dev
+ ffmpeg-dev
+ kcoreaddons5-dev
+ ki18n5-dev
mauikit-dev
mauikit-filebrowsing-dev
mpv-dev
@@ -24,25 +24,28 @@ makedepends="
qt5-qtdeclarative-dev
qt5-qtmultimedia-dev
qt5-qtxmlpatterns-dev
+ samurai
+ taglib-dev
"
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/maui/clip.git"
source="https://download.kde.org/stable/maui/clip/$pkgver/clip-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-ea2a79a5f04e03b221ea66aa1ec82b7da7ca3c54e7047b541f39f28b677ea9b7fab73e21c40a4f1051bc05bd1833f2288e8721c4f382872791c153760af26917 clip-2.0.0.tar.xz
+00e8a1bff92b1d1e930d74be584fb4181debc29bdb30ef63780d44ef13bc460672b0a177fe21ece6fa9effe8c8259f9e23174080b1617ca9cc808c4cd595f4b4 clip-3.0.2.tar.xz
"