aboutsummaryrefslogtreecommitdiffstats
path: root/community/clip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/clip/APKBUILD')
-rw-r--r--community/clip/APKBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/community/clip/APKBUILD b/community/clip/APKBUILD
index c40826f8fcc..c099d4b6a07 100644
--- a/community/clip/APKBUILD
+++ b/community/clip/APKBUILD
@@ -1,22 +1,22 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
pkgname=clip
-pkgver=2.1.2
-pkgrel=1
+pkgver=3.0.2
+pkgrel=0
pkgdesc="Video player and video collection manager"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by mauikit
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://invent.kde.org/maui/clip"
license="GPL-3.0-or-later"
-depends="
- qt5-qtbase-sqlite
- "
+depends="qt5-qtbase-sqlite"
makedepends="
extra-cmake-modules
ffmpeg-dev
- kcoreaddons-dev
- ki18n-dev
+ kcoreaddons5-dev
+ ki18n5-dev
mauikit-dev
mauikit-filebrowsing-dev
mpv-dev
@@ -28,6 +28,7 @@ makedepends="
taglib-dev
"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/maui/clip.git"
source="https://download.kde.org/stable/maui/clip/$pkgver/clip-$pkgver.tar.xz"
options="!check" # No tests
@@ -39,13 +40,12 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-fdc1787e484ed1363c48eefb5622f209a3a2f43cf0cae2df576360aff6a1e6e1e6475424241f409f06aa7c6f4d1b5f10a6998f5e208a2ae391ecb2f7cf74c773 clip-2.1.2.tar.xz
+00e8a1bff92b1d1e930d74be584fb4181debc29bdb30ef63780d44ef13bc460672b0a177fe21ece6fa9effe8c8259f9e23174080b1617ca9cc808c4cd595f4b4 clip-3.0.2.tar.xz
"