aboutsummaryrefslogtreecommitdiffstats
path: root/community/cloud-init/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cloud-init/APKBUILD')
-rw-r--r--community/cloud-init/APKBUILD115
1 files changed, 73 insertions, 42 deletions
diff --git a/community/cloud-init/APKBUILD b/community/cloud-init/APKBUILD
index d4308785de0..dc2d29ee9f2 100644
--- a/community/cloud-init/APKBUILD
+++ b/community/cloud-init/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Matt Dainty <matt+alpine@bodgit-n-scarper.com>
# Contributor: Dermot Bradley <dermot_bradley@yahoo.com>
-# Maintainer: Dermot Bradley <dermot_bradley@yahoo.com>
+# Maintainer:
pkgname=cloud-init
-pkgver=22.2.2
-pkgrel=0
+pkgver=24.1.3
+pkgrel=1
pkgdesc="Cloud instance init scripts"
url="https://cloud-init.io"
# Dependant package "cloud-utils-growpart" is not available for
@@ -13,20 +13,15 @@ license="Apache-2.0 OR GPL-3.0-only"
depends="
blkid
cloud-utils-growpart
- eudev
- ifupdown-ng
iproute2-minimal
- lsblk
- parted
python3
py3-configobj
py3-jinja2
py3-jsonpatch
py3-jsonschema
+ py3-netifaces
py3-requests
py3-yaml
- sfdisk
- sgdisk
shadow
tzdata
"
@@ -35,22 +30,29 @@ checkdepends="
bash
coreutils
grep
- py3-httpretty
+ lsblk
+ parted
+ procps-ng
py3-netifaces
+ py3-passlib
+ py3-pyserial
py3-pytest
py3-pytest-mock
py3-responses
+ py3-tox
+ sfdisk
+ sgdisk
"
subpackages="
$pkgname-bash-completion
$pkgname-doc
+ $pkgname-logrotate
+ $pkgname-pyc
$pkgname-openrc
"
-source="cloud-init-$pkgver.tar.gz::https://github.com/canonical/cloud-init/archive/$pkgver.tar.gz
+source="cloud-init-$pkgver.tar.gz::https://github.com/canonical/cloud-init/archive/refs/tags/$pkgver.tar.gz
01-oauthlib-remove.patch
- 02-disable-irrelevant-modules.patch
- 03-hook-hotplug-sh.patch
- 04-add-doas.patch
+ 04-set-default-datasource-list.patch
cloud-init-hotplugd
cloud-init-hotplugd.initd
cloud-init.logrotate
@@ -61,6 +63,8 @@ source="cloud-init-$pkgver.tar.gz::https://github.com/canonical/cloud-init/archi
install="$pkgname.post-install"
# secfixes:
+# 23.1.2-r0:
+# - CVE-2023-1786
# 22.2.2-r0:
# - CVE-2022-2084
# 21.1-r1:
@@ -75,18 +79,21 @@ build() {
}
check() {
- python3 -m pytest
+ # https://github.com/canonical/cloud-init/issues/5158
+ local k="not test_parse_unexpected_timestamp_format_with_date_command"
+ k="$k and not test_parse_logline_returns_event_for_amazon_linux_2_line"
+
+ python3 -m pytest -k "$k"
}
package() {
python3 setup.py install \
--prefix=/usr --root="$pkgdir" --init-system=sysvinit_openrc
- mkdir -p \
- "$pkgdir"/etc/network
install -m644 \
+ -D \
"$srcdir"/interfaces \
- "$pkgdir"/etc/network/
+ "$pkgdir"/etc/network/interfaces
install -m755 \
-D \
@@ -116,8 +123,9 @@ package() {
# Delete non-Alpine distribution template files
for distro in \
- arch debian fedora freebsd gentoo opensuse photon redhat \
- rhel sles suse ubuntu
+ arch centos cos debian fedora freebsd gentoo mariner openbsd \
+ opensuse opensuse-leap opensuse-microos opensuse-tumbleweed \
+ photon redhat rhel sle_hpc sle-micro sles suse ubuntu
do
for file in \
"$pkgdir"/etc/cloud/templates/*."$distro".tmpl
@@ -125,6 +133,22 @@ package() {
rm "$file"
done
done
+ rm "$pkgdir"/etc/cloud/templates/sources.list.*.tmpl
+
+ # Delete non-Alpine os-specific files
+ for distro in \
+ almalinux amazon arch bsd centos cloudlinux cos debian \
+ dragonflybsd eurolinux fedora freebsd gentoo mariner \
+ miraclelinux netbsd openeuler openbsd OpenCloudOS \
+ openmandriva opensuse opensuse-leap opensuse-microos \
+ opensuse-tumbleweed photon rhel rhel_util rocky sle-micro \
+ sle_hpc sles suse TencentOS ubuntu virtuozzo
+ do
+ rm "$pkgdir"/usr/lib/python3.*/site-packages/cloudinit/distros/"$distro".py
+ rm "$pkgdir"/usr/lib/python3.*/site-packages/cloudinit/distros/__pycache__/"$distro".*.pyc
+ done
+ rm "$pkgdir"/usr/lib/python3.*/site-packages/cloudinit/distros/parsers/sys_conf.py
+ rm "$pkgdir"/usr/lib/python3.*/site-packages/cloudinit/distros/parsers/__pycache__/sys_conf.*.pyc
# Delete systemd-related files
rm \
@@ -137,22 +161,23 @@ package() {
# Delete cloud-init modules not relevant to Alpine
for module in \
- cc_apt_*.py \
- cc_fan.py \
- cc_grub_dpkg.py \
- cc_landscape.py \
- cc_refresh_rmc_and_interface.py \
- cc_reset_rmc.py \
- cc_rh_subscription.py \
- cc_snap.py \
- cc_ssh_import_id.py \
- cc_spacewalk.py \
- cc_ubuntu_advantage.py \
- cc_ubuntu_drivers.py \
- cc_yum_add_repo.py \
- cc_zypper_add_repo.py
+ apt_* \
+ byobu \
+ fan \
+ grub_dpkg \
+ landscape \
+ lxd \
+ reset_rmc \
+ rh_subscription \
+ snap \
+ spacewalk \
+ ubuntu_autoinstall \
+ ubuntu_drivers \
+ yum_add_repo \
+ zypper_add_repo
do
- rm "$pkgdir"/usr/lib/python3.*/site-packages/cloudinit/config/$module
+ rm "$pkgdir"/usr/lib/python3.*/site-packages/cloudinit/config/cc_$module.py
+ rm "$pkgdir"/usr/lib/python3.*/site-packages/cloudinit/config/__pycache__/cc_$module.*.pyc
done
# Delete cloud-init docs not relevant to Alpine
@@ -166,16 +191,22 @@ package() {
done
}
+logrotate() {
+ pkgdesc="Cloud instance init scripts (logrotate configuration)"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel logrotate"
+
+ amove etc/logrotate.d/cloud-init
+}
+
sha512sums="
-bc8e76d6e862b620cbe2b04e2034dcfa9cd2f19586b4934b4d79ad7ce4b4e7a6679c677738e41942e318392729bbfcdd16e1767dfc34701140db36e3e90ccdb8 cloud-init-22.2.2.tar.gz
+cc2a86637926ee2201a186f4f68fd579a1a9f7b4649ab5e90fe5fcd975a45fcf893e2fbe272ae9829ce8dca4faadc82bb9fde8b957d8e1ef7769686ee0aeefe8 cloud-init-24.1.3.tar.gz
c14ce3b27c55d1c381e27b2898bb73da8a74c53480d496bdfc87318b69fb612678205ab5a686c1ce703ef5c2c7a8529f629c8f908aeff39524d36870a83c1929 01-oauthlib-remove.patch
-945eb69143a6c35ecbef1dcdec483e8cacc0dcbea6365160ed6c251629c56676edd4494e66768fafd47e48346d3b0af986290ac85c9983fa3179b60cc066e7e9 02-disable-irrelevant-modules.patch
-463d7ca00f576de75444e86d9b32e1452c824a9f2708b624549e7e003b330c96fbc78d44756efd95d1f954fa0633ce0c0b619e798cdb33b8c86799ee07554834 03-hook-hotplug-sh.patch
-592cbbbe1520cf272a8721ed284a8a96c4077577d00a438f608ce1f35b9f18e3b7fdd9ac1fb44663981f80caf1ef1c87e4b384a986283c167a526a1b24c44d82 04-add-doas.patch
-3c6c5189859633012fd389a8d8370cbd46ddd07f206d61bcf872f12105f340552073cbf28f28096109c158b641de1c8199afcfc7f751166a27d4089355e1dd7d cloud-init.logrotate
+8174411925f40f7e0eabb43cfdc273dfd0cf069e3713a3883ed128df7a5cc80b7d19e2643629cf17ae65c3d8e59cc8a074ca5932a6a4fe0e8299fad9ce861686 04-set-default-datasource-list.patch
2d7b80fc248ec18f20c4ed2fbe0f8d6ea85ae57a0ece8ecf8a095cf910c576807c19ab0453c00160b85253df5725cba90abec731cb54f441a509611115519b46 cloud-init-hotplugd
ab44fc51979a5da8569b08ed2f290a6610de6c36cf147af20f30e9224847623d3594c056a1f64c614598ac130e9bec92d566fb901024f806b768a89190c45f59 cloud-init-hotplugd.initd
+3c6c5189859633012fd389a8d8370cbd46ddd07f206d61bcf872f12105f340552073cbf28f28096109c158b641de1c8199afcfc7f751166a27d4089355e1dd7d cloud-init.logrotate
48b25ec4457c2b3772a7d210033551d041749a0d1869818d888030e6df7fd9bbc13a38b95cf465de3d46d96881a722f94a337584ce48f280c4a52b819586563a interfaces
-b82e06afa27de5880245ed5593157b38e18a77eac5284b6f40095709edf16390322d86755651c36bbcc545f5f840c58a8f74593a785ef016a3aec2a4fe256ad3 setup-cloud-init
-8af764e82246a6417d9604ad93c080f3d3b7442937e0ccfd1fe47f9b5b3e0d5d81c5319aae27bf832909da9411bdf15f670e8425fbc99ed53e519f8ab61e4925 README.Alpine
+9340e30b6c95f66cb2cdc68c0c5d765e4ce879d2f2bfb042c4b45996cf2b5c542b3762c6abfd213b4b9610f290d6ca734c28c7240fea76fb5cf58253570d2e8f setup-cloud-init
+748b828de1f21cc30c9c13c4ebfbec5ba542ed882ddd04906661ffd7e50ef3d575f67d5650e99aac01fb8c84a9dc84cc73d2c8f232f0d4cfe86136f3097676cf README.Alpine
"