aboutsummaryrefslogtreecommitdiffstats
path: root/community/cloudflare-ddns/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cloudflare-ddns/APKBUILD')
-rw-r--r--community/cloudflare-ddns/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/cloudflare-ddns/APKBUILD b/community/cloudflare-ddns/APKBUILD
index af01323ecf6..3a61a9374da 100644
--- a/community/cloudflare-ddns/APKBUILD
+++ b/community/cloudflare-ddns/APKBUILD
@@ -1,23 +1,26 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cloudflare-ddns
-pkgver=1.3.0
-pkgrel=4
+pkgver=1.4.0
+pkgrel=3
pkgdesc="DDNS script to sync public IP address to CloudFlare dns records"
options="!check" # No testsuite
-url="https://github.com/ailionx/cloudflare-ddns"
+url="https://github.com/undefinedplayer/cloudflare-ddns"
arch="noarch"
license="MIT"
depends="py3-requests"
makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ailionx/cloudflare-ddns/archive/$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/undefinedplayer/cloudflare-ddns/archive/$pkgver.tar.gz"
build() {
python3 setup.py build
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="b059b7795bb26de2c83e3619a5dba281bfacbbf0fa33a5678846043d64f805b8f40c3266e246f1dfd36003205babed4938a039f9f669aabedf9903ca0360a867 cloudflare-ddns-1.3.0.tar.gz"
+sha512sums="
+2c52153e0e4d44a504268474d1448d6729a11d457ca7d94599bd93baa4e2e0d08e96eebe4411119f2e1d6a464ddc9582470d8308afda71217bc4218afe42bef3 cloudflare-ddns-1.4.0.tar.gz
+"