aboutsummaryrefslogtreecommitdiffstats
path: root/community/cmake-extras/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cmake-extras/APKBUILD')
-rw-r--r--community/cmake-extras/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/cmake-extras/APKBUILD b/community/cmake-extras/APKBUILD
new file mode 100644
index 00000000000..ccb9ba29419
--- /dev/null
+++ b/community/cmake-extras/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname=cmake-extras
+pkgver=1.7
+pkgrel=0
+pkgdesc="A collection of add-ons for the CMake build tool"
+url="https://gitlab.com/ubports/development/core/cmake-extras"
+arch="noarch"
+license="LGPL-3.0-only"
+depends="cmake"
+makedepends="samurai"
+options="!check" # No testsuite
+source="https://gitlab.com/ubports/development/core/cmake-extras/-/archive/$pkgver/cmake-extras-$pkgver.tar.gz"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+
+sha512sums="
+007a6bc247746196873e10584957fc7269776b7cd6e0a7b7c0701e8807c8e42bfdf6c71a92f13ed8961930260c6e62a7aef41840a7b79725fed182d59bb78621 cmake-extras-1.7.tar.gz
+"