aboutsummaryrefslogtreecommitdiffstats
path: root/community/cmake-extras/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cmake-extras/APKBUILD')
-rw-r--r--community/cmake-extras/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/community/cmake-extras/APKBUILD b/community/cmake-extras/APKBUILD
index 7203bdf4b2f..ccb9ba29419 100644
--- a/community/cmake-extras/APKBUILD
+++ b/community/cmake-extras/APKBUILD
@@ -1,23 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname=cmake-extras
-pkgver=0_git20210528
+pkgver=1.7
pkgrel=0
-_commit="87ffd0dd75e0f6ba7ae499af5c1f26f3f9ebe204"
pkgdesc="A collection of add-ons for the CMake build tool"
-url="https://gitlab.com/ubports/core/cmake-extras"
+url="https://gitlab.com/ubports/development/core/cmake-extras"
arch="noarch"
license="LGPL-3.0-only"
depends="cmake"
+makedepends="samurai"
options="!check" # No testsuite
-source="https://gitlab.com/ubports/core/cmake-extras/-/archive/$_commit/cmake-extras-$_commit.tar.gz
- 0001-GMock-Extract-version-detection-code-into-function.patch
- 0002-GMock-Use-GMock-targets-from-CMake-if-possible.patch
- "
-builddir="$srcdir/$pkgname-$_commit"
+source="https://gitlab.com/ubports/development/core/cmake-extras/-/archive/$pkgver/cmake-extras-$pkgver.tar.gz"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
@@ -28,7 +24,5 @@ package() {
}
sha512sums="
-977890bba9d537de4b9578bb134e68ba2a3c18251023f73d73355cd5446dc669670fe6ddac578417fcaabe9ede1c34e52b2b2fb93f168a40fd8d55ee396263a8 cmake-extras-87ffd0dd75e0f6ba7ae499af5c1f26f3f9ebe204.tar.gz
-962eacb3f012bcb302911d684a2bfafd23b6e924cbf8365c04a3cbf575e714a819a8cbed5890646dc4e92ee6d73614923091176657c11f6f5cd7e9dd262135d8 0001-GMock-Extract-version-detection-code-into-function.patch
-835dec52303d4ff212f6a82e7ad768d8472c5ba00104c64ce25356461e63b00820f901914a1f2d28cf3f59ee1cd57edacb422688e93da81f5ad84c162fe8b51d 0002-GMock-Use-GMock-targets-from-CMake-if-possible.patch
+007a6bc247746196873e10584957fc7269776b7cd6e0a7b7c0701e8807c8e42bfdf6c71a92f13ed8961930260c6e62a7aef41840a7b79725fed182d59bb78621 cmake-extras-1.7.tar.gz
"