aboutsummaryrefslogtreecommitdiffstats
path: root/community/coeurl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/coeurl/APKBUILD')
-rw-r--r--community/coeurl/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/community/coeurl/APKBUILD b/community/coeurl/APKBUILD
index b3d357b8842..d8836c1ebdf 100644
--- a/community/coeurl/APKBUILD
+++ b/community/coeurl/APKBUILD
@@ -1,24 +1,28 @@
# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=coeurl
-pkgver=0.2.0
-pkgrel=0
+pkgver=0.3.0
+pkgrel=3
pkgdesc="Asynchronous wrapper around libcurl"
url="https://nheko.im/nheko-reborn/coeurl"
arch="all"
license="MIT"
-makedepends="cmake curl-dev libevent-dev meson spdlog-dev"
+makedepends="curl-dev libevent-dev meson spdlog-dev"
subpackages="$pkgname-dev"
-source="https://nheko.im/nheko-reborn/coeurl/-/archive/v$pkgver/coeurl-v$pkgver.tar.bz2"
+source="https://nheko.im/nheko-reborn/coeurl/-/archive/v$pkgver/coeurl-v$pkgver.tar.bz2
+ 0001-curl-7.85.00-deprecation-for-CURLOPT_PROTOCOLS.patch
+ 0002-Fix-build-with-fmt10.patch
+ 0003-Fix-provides-section-in-wraps.patch
+ "
builddir="$srcdir/$pkgname-v$pkgver"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -26,5 +30,8 @@ package() {
}
sha512sums="
-de5f405b6993a33cf958996430d0f7a25cccb47488c3c2ce44525630e533a5acd1d630e2293cdae74befc627de81b211b4a9b6d53138f3de1d92f267f016e4fb coeurl-v0.2.0.tar.bz2
+4ad5a279689ad360f7b33f110e3bf174578655ab036405789d43bcbc73f775c51ab69cb20e79e1229ba045414a2d46e97869a0cd62b978e518cdf23a86b0a846 coeurl-v0.3.0.tar.bz2
+82376f882c0801dc9caabb3ccb3c9a5ff8eb50b585fbe15b6c51d3a69b9fbc40d3035fc31d48abb3e5f58d92aa0b206b5b43729a60dec55ef59220a1a91a1753 0001-curl-7.85.00-deprecation-for-CURLOPT_PROTOCOLS.patch
+4765d5f920e176a7455baa64d922d6cbca51fe61eaffffb97e0d0bbf1be59486851f910e306c6ff056bae349d6e0a02d2db1a9f8db9cfcf21b8076e2ac0cbaa0 0002-Fix-build-with-fmt10.patch
+bf65d11384d97a80bbe7b40e45ccd5ec4ecdc28e4bb8db5e5e8e404da92a96888f68d87f13a7c23eb4b284ca63a415eeb2a0757a73c167342595b67dbf5e7f87 0003-Fix-provides-section-in-wraps.patch
"