aboutsummaryrefslogtreecommitdiffstats
path: root/community/coeurl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/coeurl/APKBUILD')
-rw-r--r--community/coeurl/APKBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/community/coeurl/APKBUILD b/community/coeurl/APKBUILD
index 07f55cfb9ba..d8836c1ebdf 100644
--- a/community/coeurl/APKBUILD
+++ b/community/coeurl/APKBUILD
@@ -1,30 +1,28 @@
# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=coeurl
-pkgver=0.1.0
-pkgrel=0
+pkgver=0.3.0
+pkgrel=3
pkgdesc="Asynchronous wrapper around libcurl"
url="https://nheko.im/nheko-reborn/coeurl"
arch="all"
license="MIT"
-makedepends="cmake curl-dev libevent-dev meson spdlog-dev"
+makedepends="curl-dev libevent-dev meson spdlog-dev"
subpackages="$pkgname-dev"
-source="https://nheko.im/nheko-reborn/coeurl/-/archive/v0.1.0/coeurl-v0.1.0.tar.bz2"
+source="https://nheko.im/nheko-reborn/coeurl/-/archive/v$pkgver/coeurl-v$pkgver.tar.bz2
+ 0001-curl-7.85.00-deprecation-for-CURLOPT_PROTOCOLS.patch
+ 0002-Fix-build-with-fmt10.patch
+ 0003-Fix-provides-section-in-wraps.patch
+ "
builddir="$srcdir/$pkgname-v$pkgver"
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
- . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -32,5 +30,8 @@ package() {
}
sha512sums="
-a84c56b644ffae30e73f945719b524f546ea19a895b63b8d7c9b11bad95c7d2bf12956199b5a705980d9c227933ad0667478a62db8a0d15a7699febce3ba74a7 coeurl-v0.1.0.tar.bz2
+4ad5a279689ad360f7b33f110e3bf174578655ab036405789d43bcbc73f775c51ab69cb20e79e1229ba045414a2d46e97869a0cd62b978e518cdf23a86b0a846 coeurl-v0.3.0.tar.bz2
+82376f882c0801dc9caabb3ccb3c9a5ff8eb50b585fbe15b6c51d3a69b9fbc40d3035fc31d48abb3e5f58d92aa0b206b5b43729a60dec55ef59220a1a91a1753 0001-curl-7.85.00-deprecation-for-CURLOPT_PROTOCOLS.patch
+4765d5f920e176a7455baa64d922d6cbca51fe61eaffffb97e0d0bbf1be59486851f910e306c6ff056bae349d6e0a02d2db1a9f8db9cfcf21b8076e2ac0cbaa0 0002-Fix-build-with-fmt10.patch
+bf65d11384d97a80bbe7b40e45ccd5ec4ecdc28e4bb8db5e5e8e404da92a96888f68d87f13a7c23eb4b284ca63a415eeb2a0757a73c167342595b67dbf5e7f87 0003-Fix-provides-section-in-wraps.patch
"