aboutsummaryrefslogtreecommitdiffstats
path: root/community/coeurl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/coeurl/APKBUILD')
-rw-r--r--community/coeurl/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/coeurl/APKBUILD b/community/coeurl/APKBUILD
new file mode 100644
index 00000000000..d8836c1ebdf
--- /dev/null
+++ b/community/coeurl/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=coeurl
+pkgver=0.3.0
+pkgrel=3
+pkgdesc="Asynchronous wrapper around libcurl"
+url="https://nheko.im/nheko-reborn/coeurl"
+arch="all"
+license="MIT"
+makedepends="curl-dev libevent-dev meson spdlog-dev"
+subpackages="$pkgname-dev"
+source="https://nheko.im/nheko-reborn/coeurl/-/archive/v$pkgver/coeurl-v$pkgver.tar.bz2
+ 0001-curl-7.85.00-deprecation-for-CURLOPT_PROTOCOLS.patch
+ 0002-Fix-build-with-fmt10.patch
+ 0003-Fix-provides-section-in-wraps.patch
+ "
+builddir="$srcdir/$pkgname-v$pkgver"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+4ad5a279689ad360f7b33f110e3bf174578655ab036405789d43bcbc73f775c51ab69cb20e79e1229ba045414a2d46e97869a0cd62b978e518cdf23a86b0a846 coeurl-v0.3.0.tar.bz2
+82376f882c0801dc9caabb3ccb3c9a5ff8eb50b585fbe15b6c51d3a69b9fbc40d3035fc31d48abb3e5f58d92aa0b206b5b43729a60dec55ef59220a1a91a1753 0001-curl-7.85.00-deprecation-for-CURLOPT_PROTOCOLS.patch
+4765d5f920e176a7455baa64d922d6cbca51fe61eaffffb97e0d0bbf1be59486851f910e306c6ff056bae349d6e0a02d2db1a9f8db9cfcf21b8076e2ac0cbaa0 0002-Fix-build-with-fmt10.patch
+bf65d11384d97a80bbe7b40e45ccd5ec4ecdc28e4bb8db5e5e8e404da92a96888f68d87f13a7c23eb4b284ca63a415eeb2a0757a73c167342595b67dbf5e7f87 0003-Fix-provides-section-in-wraps.patch
+"