aboutsummaryrefslogtreecommitdiffstats
path: root/community/colord-gtk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/colord-gtk/APKBUILD')
-rw-r--r--community/colord-gtk/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/colord-gtk/APKBUILD b/community/colord-gtk/APKBUILD
index e2f274f1639..ea51ffe9281 100644
--- a/community/colord-gtk/APKBUILD
+++ b/community/colord-gtk/APKBUILD
@@ -1,14 +1,20 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=colord-gtk
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=0
pkgdesc="GTK support library for colord"
options="!check" # Requires bus session
url="https://www.freedesktop.org/software/colord/"
-# s390x and riscv64 blocked by polkit -> colord
-arch="all !s390x !riscv64"
+arch="all"
license="LGPL-2.1-or-later"
-makedepends="meson intltool glib-dev gtk+3.0-dev gtk4.0-dev colord-dev lcms2-dev"
+makedepends="
+ colord-dev
+ glib-dev
+ gtk+3.0-dev
+ gtk4.0-dev
+ lcms2-dev
+ meson
+ "
checkdepends="xvfb-run"
subpackages="$pkgname-dev $pkgname-lang"
source="https://www.freedesktop.org/software/colord/releases/colord-gtk-$pkgver.tar.xz"
@@ -21,11 +27,11 @@ build() {
-Dman=false \
-Ddocs=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -33,5 +39,5 @@ package() {
}
sha512sums="
-95ea9e8925d56462b8e5230a6737ca8e75d2273b2803e00f7aa2f933d22f88373194dccc00117fce85579274cc0daf88876fa265510580b1610734bb45220896 colord-gtk-0.3.0.tar.xz
+d8ac4e6f32a0672cd4e87585a03e82ecfc359ae4b99a4a6529ad81025f9beec5a3b479e94dff9a7e49db03e99671099b7f8370f6f87791e5a9fc008da859b238 colord-gtk-0.3.1.tar.xz
"