aboutsummaryrefslogtreecommitdiffstats
path: root/community/communicator/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/communicator/APKBUILD')
-rw-r--r--community/communicator/APKBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/community/communicator/APKBUILD b/community/communicator/APKBUILD
index 47c881882bd..e1cdde7c589 100644
--- a/community/communicator/APKBUILD
+++ b/community/communicator/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
pkgname=communicator
-pkgver=2.1.0
+pkgver=3.0.2
pkgrel=0
pkgdesc="Contacts and dialer application"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by mauikit
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://invent.kde.org/maui/communicator"
license="GPL-3.0-or-later"
depends="
@@ -15,35 +17,37 @@ depends="
"
makedepends="
extra-cmake-modules
- kcontacts-dev
- kcoreaddons-dev
- ki18n-dev
- kpeople-dev
- kservice-dev
+ kcontacts5-dev
+ kcoreaddons5-dev
+ ki18n5-dev
+ kpeople5-dev
+ kservice5-dev
mauikit-dev
mauikit-filebrowsing-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtquickcontrols2-dev
+ samurai
"
+_repo_url="https://invent.kde.org/maui/communicator.git"
source="https://download.kde.org/stable/maui/communicator/$pkgver/communicator-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-c6c8539e1e70ac5ebfeded4b902ce6016c27d6489d254cec9183698b52b2188cd1c14be528e62940f62af9fe2753bbc8b4bc93ab89982eaae90a9b1d357d62c2 communicator-2.1.0.tar.xz
+f630d454ae7dacf95cd44718e4b36cc78a8af8aea2e2eee0d66d1e4a2194c98bd1305843b41af62e95a241c2fe4682cd385b133e9a2f034b0295aee3b63188b7 communicator-3.0.2.tar.xz
"