aboutsummaryrefslogtreecommitdiffstats
path: root/community/communicator/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/communicator/APKBUILD')
-rw-r--r--community/communicator/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/community/communicator/APKBUILD b/community/communicator/APKBUILD
new file mode 100644
index 00000000000..e1cdde7c589
--- /dev/null
+++ b/community/communicator/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
+pkgname=communicator
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="Contacts and dialer application"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
+url="https://invent.kde.org/maui/communicator"
+license="GPL-3.0-or-later"
+depends="
+ mauikit-filebrowsing
+ mauikit-texteditor
+ "
+makedepends="
+ extra-cmake-modules
+ kcontacts5-dev
+ kcoreaddons5-dev
+ ki18n5-dev
+ kpeople5-dev
+ kservice5-dev
+ mauikit-dev
+ mauikit-filebrowsing-dev
+ qt5-qtbase-dev
+ qt5-qtdeclarative-dev
+ qt5-qtquickcontrols2-dev
+ samurai
+ "
+_repo_url="https://invent.kde.org/maui/communicator.git"
+source="https://download.kde.org/stable/maui/communicator/$pkgver/communicator-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+options="!check" # No tests
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+sha512sums="
+f630d454ae7dacf95cd44718e4b36cc78a8af8aea2e2eee0d66d1e4a2194c98bd1305843b41af62e95a241c2fe4682cd385b133e9a2f034b0295aee3b63188b7 communicator-3.0.2.tar.xz
+"