aboutsummaryrefslogtreecommitdiffstats
path: root/community/communicator/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/communicator/APKBUILD')
-rw-r--r--community/communicator/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/communicator/APKBUILD b/community/communicator/APKBUILD
index 995193f3590..e1cdde7c589 100644
--- a/community/communicator/APKBUILD
+++ b/community/communicator/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
pkgname=communicator
-pkgver=2.1.2
+pkgver=3.0.2
pkgrel=0
pkgdesc="Contacts and dialer application"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by mauikit
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://invent.kde.org/maui/communicator"
license="GPL-3.0-or-later"
depends="
@@ -15,11 +17,11 @@ depends="
"
makedepends="
extra-cmake-modules
- kcontacts-dev
- kcoreaddons-dev
- ki18n-dev
- kpeople-dev
- kservice-dev
+ kcontacts5-dev
+ kcoreaddons5-dev
+ ki18n5-dev
+ kpeople5-dev
+ kservice5-dev
mauikit-dev
mauikit-filebrowsing-dev
qt5-qtbase-dev
@@ -27,7 +29,9 @@ makedepends="
qt5-qtquickcontrols2-dev
samurai
"
+_repo_url="https://invent.kde.org/maui/communicator.git"
source="https://download.kde.org/stable/maui/communicator/$pkgver/communicator-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
options="!check" # No tests
build() {
@@ -38,13 +42,12 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-ea25447ca8f2a380e758345a0ce750163558e896837a4ff12ded6469a5a735bebcbceb3823da4a593d3f276e4ad277f58dbbc9bee9bf9040eb9a8bc86ee641c2 communicator-2.1.2.tar.xz
+f630d454ae7dacf95cd44718e4b36cc78a8af8aea2e2eee0d66d1e4a2194c98bd1305843b41af62e95a241c2fe4682cd385b133e9a2f034b0295aee3b63188b7 communicator-3.0.2.tar.xz
"