aboutsummaryrefslogtreecommitdiffstats
path: root/community/compton
diff options
context:
space:
mode:
Diffstat (limited to 'community/compton')
-rw-r--r--community/compton/APKBUILD24
1 files changed, 6 insertions, 18 deletions
diff --git a/community/compton/APKBUILD b/community/compton/APKBUILD
index b4f2cc6bf55..3c7d7ba02cc 100644
--- a/community/compton/APKBUILD
+++ b/community/compton/APKBUILD
@@ -2,38 +2,26 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=compton
pkgver=0.1_beta2
-pkgrel=0
+pkgrel=1
pkgdesc="X Compositor (a fork of xcompmgr-dana)"
url="https://github.com/chjj/compton"
arch="all"
license="MIT"
-depends=""
-depends_dev="libx11-dev libxcomposite-dev libxinerama-dev libxdamage-dev \
- libconfig-dev pcre-dev libxrandr-dev dbus-dev libdrm-dev mesa-dev"
-makedepends="$depends_dev asciidoc"
+makedepends="libx11-dev libxcomposite-dev libxinerama-dev libxdamage-dev \
+ libconfig-dev pcre-dev libxrandr-dev dbus-dev libdrm-dev mesa-dev asciidoc"
install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/chjj/$pkgname/archive/v$pkgver.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- sed -i "s:\(COMPTON_VERSION ?= \)git.*:\1v${pkgver}:" Makefile
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
make PREFIX=/usr
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make PREFIX="$pkgdir"/usr install
install -D -m644 "LICENSE" "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
install -D -m644 "compton.sample.conf" "$pkgdir/etc/xdg/compton.conf.example"