aboutsummaryrefslogtreecommitdiffstats
path: root/community/connman-resolvconf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/connman-resolvconf/APKBUILD')
-rw-r--r--community/connman-resolvconf/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/connman-resolvconf/APKBUILD b/community/connman-resolvconf/APKBUILD
index 9ba9f818998..bd581ea5b07 100644
--- a/community/connman-resolvconf/APKBUILD
+++ b/community/connman-resolvconf/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=connman-resolvconf
-pkgver=0.1.0
-pkgrel=0
+pkgver=0.2.0
+pkgrel=2
pkgdesc="ConnMan integration with resolvconf(8)"
url="https://github.com/jirutka/connman-resolvconf"
arch="aarch64 armhf armv7 ppc64le x86 x86_64" # blocked by rust/cargo
@@ -12,19 +12,20 @@ depends="
connman
dbus
"
-makedepends="cargo dbus-dev"
+makedepends="cargo dbus-dev cargo-auditable"
subpackages="$pkgname-openrc"
source="https://github.com/jirutka/connman-resolvconf/archive/v$pkgver/connman-resolvconf-$pkgver.tar.gz"
options="!check" # no tests provided
+
prepare() {
default_prepare
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build --frozen --release
+ cargo auditable build --frozen --release
}
package() {
@@ -34,5 +35,5 @@ package() {
}
sha512sums="
-a07ea50e0e1d0c12c60b59dfcbdedabdaacc6d336ea72bbe608558ad79d687f641e4fa08e9efd74e1761b07b938fd202214b0c0770f8bfffda4f3daae7e93765 connman-resolvconf-0.1.0.tar.gz
+66addbf52084ca2c46a13e57d10d9acd2a10e39e166bc910d8910cc44ddaf734aff2f8cbf393eb7e4e26c9733364ced1199384b69a69b79e3491e72f4f327ccc connman-resolvconf-0.2.0.tar.gz
"